Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to run an image which I took from an actual PC (cpu = intel/motherboard=unknown to me/ os = FC 4/ RAID disk controller) and I want to run that image under virtual machine (vmware/virtualbox/virtual SCSI disk controller/cpu=amd) and all the time grub will freeze on following line : "GRUB "

I have used FC4 rescue cd and tried following commands :

chroot /mnt/sysimage/
grub-install /dev/sda/

error : does not have any corresponding BIOS drive.

or

grub
find /boot/.....
error : Error 15: File not found

Honestly, I don't have any idea how I can fix this image so it would run under virtual machine.

and this is my

fdisk -l 

output redhat fedora core 4 screenshot

Help please.

share|improve this question
1  
/dev/sda/ would point to a directory, but /dev/sda is a file. Try it and see if it helps. –  gronostaj Mar 27 '13 at 14:04
    
the same error. –  austin powers Mar 27 '13 at 14:12

1 Answer 1

Solved this problem,

Solution for my case :

after booting with rescue CD :

chroot /mnt/sysimage/

grub

root (hd0,0)

find /grub/grub.conf

setup (hd0)

reboot

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.