Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Are there any included tools in Windows 7 which would help me determine why it keeps showing me this welcome screen for minutes after the login?

I like the tools which sometimes inform me about the drivers provoking a bluescreen or other problems. But I couldn't find any way to see why my machine takes so long to show me the desktop.

UPDATE:

  • The computer is in a domain
  • The antivirus is Microsoft Security Essentials

UPDATE 2:
Using MSCONFIG I disabled all services (except those from Microsoft) and all startup items. This resulted in no change.
I then chose to boot "Diagnostic setup" in MSCONFIG which seems to disable all services including those from Microsoft and now the welcome message didn't hang that long anymore.
So now it would be interesting to find which MS service is producing this...

share|improve this question
    
Go look in the Event viewer. They have a whole lot of info in there now for this sort of thing. –  user3463 Oct 19 '09 at 13:37
1  
Is the computer in a domain? –  Chris_K Oct 19 '09 at 13:46
    
I see a change here. Windows Vista usually makes me wait for about one minute before the login. –  Daniel Daranas Oct 19 '09 at 13:48
1  
Yes, the computer is in a domain. But it's slow even when the network cable is attached so the controller can be found immediatly. And yes, Vista always took so long before you see the login, now with 7 it's after the login. –  Marc Oct 19 '09 at 14:01
    
I checked the event viewer already. There's nothing immediatly recognizable as being slow or with alert state. –  Marc Oct 19 '09 at 14:09

6 Answers 6

You might also want to take a look at MSCONFIG (run as administrator), look under start-up tab and remove any unwanted items. i.e. Adobe updater etc

enter image description here

So many programmes that you install add unnecessary items in your start-up list always worth clearing these out first before further troubleshooting.

share|improve this answer
    
I tried disabling all non-MS stuff via MSCONFIG. No change happened. See the update in the question. However booting in diagnostic setup via MSCONFIG did help. –  Marc Oct 23 '09 at 9:44

Have you removed the desktop wallpaper image? It has been described that for reasons not yet known, the login process is delayed substantially when no background wallpaper is selected.

share|improve this answer

As well as Scott's answer with Msconfig, I would highly recommend you take a look at Microsoft/Sysinternals Autoruns, it gives a much better look at everything that happens and starts with your computer.

It is not as easy as Msconfig for just tinkering (enabling/disabling) but is more complete and shows all startup locations.

share|improve this answer
    
I agree, Autoruns is better than all that tools –  Jet May 17 at 12:43

Under Windows 7, the desktop is only shown after it has been fully constructed and some initial services fully started.

This process starts immediately after the Login screen shows up and you should see your HDD led display some activity: a few services are being started and explorer is being started too along with the desktop and start menu construction.

If you login right after the Login screen is first displayed, you will experience a larger waiting period between the moment you hit the login button and the moment the desktop finally shows. But if you wait it out at the login screen, you will experience a faster login process.

However, any process or service being initialized during this initial procedure will necessarily affect the apparent performance of the login experience. Some slower service for instance may force a slow down of the experience.

share|improve this answer
    
I fully agree with your statements here. I'd however like to know a way to determine which service or application or driver or whatever is responsible for this slowness. –  Marc Oct 19 '09 at 13:58

WinBootInfo has a free 30-day trial. It's advertised for Vista, but likely will work for Win7.

WinBootInfo is the advanced Windows Boot Analyzer that logs drivers and applications loaded during system boot, measures Windows boot times, records CPU and I/O activity during the boot, and much more!

share|improve this answer
    
I wouldn't be that sure it works with Windows 7, as they changed quite some stuff in the boot process of Win7 compared to the one in Vista. did anyone try with Win7? –  Snark Oct 19 '09 at 15:17

I had a similar problem yesterday, but with Windows Vista. With me the Welcome screen just did not take long before disappearing, it took forever. I had to switch of the power at the socket to reboot into safe mode with networking. I found out on the internet that it was caused by the Windows Event Log service.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.