Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Problem: Can not write accents like à, ê .

Here is my configuration:

  • Windows 7
  • Keyboard configuration : French Canadian

Description: Recently (2 days before), I could type these letters à, ê, è, I used to press the accent key and the letter I want to be accentuated. That means if I want to write ê I press the key "^" before and then the key "e". It was working fine now it is not.

I didn't make any change to the system, I suspect windows updates.

Note: I have this problem only with some software: Outlook, Notepad++ wich I use all the time.

share|improve this question

migrated from stackoverflow.com Mar 27 '13 at 17:02

This question came from our site for professional and enthusiast programmers.

1  
have you tried alt+shift? –  m4573r Mar 27 '13 at 17:06
1  
This functionality is not built into windows 7, but some applications support it, like Word. I've never seen this in Notepad++, and wouldn't expect it, because I'd expect the ^ character to appear, not wait for another character to accent. –  xdumaine Mar 27 '13 at 17:06
    
Check that your keyboard layout is recognized correctly and make sure you have French installed in your language settings. Is this a French or English windows? Qwerty or azerty keyboard? –  terdon Mar 28 '13 at 0:52
add comment

1 Answer

What could have happened is that you pressed the keystroke to change the keyboard layout (most likely not on purpose). That keystroke is CTRL + SHIFT. Pressing it again will basically tell windows to switch to the next "keyboard layout" in the list of your computer.

When you install Windows vista, 7 or 8 with french canada, Windows by default will also install the layout for US qwerty based keyboards. So when you press that combination, Windows is switching to the US layout, hence why you lose your accents.

A quick fix to this problem is to press CTRL + SHIFT again to gain access to the other keyboard layout, which is most likely french canada in your case.

You could also fix the issue by deleting any keyboard layout aside of french canada (assuming you use nothing else). By doing so, even if you press that combination accidentally, it won't switch to anything else because the only thing that it sees is french canada.

share|improve this answer
    
I have access to the french keyboard, i can type the letter "é" for example without problems. this one takes only one key, but for accents like "è" it take two keys that you must press one after the other. It's working on some software and parts of the system like the execute window, the address bar of a windows but not working on others like : Outlouk, Office, textarea in a HTML page, etc . I will try again the shorcuts you proposed and give you a feed-back (i dont have acess to the other computer now ...) . –  Mahdi El Masaoudi Mar 28 '13 at 4:15
    
CTRL+SHIFT does not resolve the problem. Thank you ! –  Mahdi El Masaoudi Apr 5 '13 at 18:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.