Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have quite a toughie I am battling with.

We are administering a bunch of "digital signage PCs", and I have a curious problem where the clock would seem to just stop ticking.

I have RSS feeds, weather, and system time on the digital presentation. We normally notice the clock stopping on the presentation, as the complete presentation itself then stops. It does not "hang", it stops. Taking focus off of the signage player and onto the desktop, I can see that the time is at the exact time it "froze" on the signage screen, but it now starts counting again. Adjusting the time to the correct time immediately affects the slides, which start playing again in the signage presentation.

The PC itself always responds and never hangs. Focusing the desktop makes the system time start counting again, but only from where it last hung. Using "time" in cmd reports the same time displayed by Windows

This issue happens erratically on every other PC in a group of about 15. The PCs are new, so I doubt it's the CMOS battery.

The software developer reports they don't have any such issue reported.

A few other facts:

  • PC - small form factor media PC
  • OS - Windows 7 Starter or Home Basic, kept up-to-date via Windows Update
    • mediasignage.com digital signage software; uses Adobe AIR as the runtime
    • (N-Central) remote monitoring software
    • No antivirus (not needed)
  • PCs are generally rebooted once a day by signage software
  • PCs are on a secluded network with a 3G router serving as the WAN side. WiFi and Ethernet have been used with no discernible pattern between them.
  • Power management is set to "Always On" with a batch script on PC boot (power management kept reverting to default settings on these machines - suspending the screen when idle)
  • Have tried both using and not using the time server sync
  • Have re-installed and updated all software and cleared all possible caches
  • This issue can happen after a couple of minutes or after hours, sometimes days, of no issues

How do I finish troubleshooting this issue?

share|improve this question
    
What CPU do these machines have? Do they have any unusual hardware or drivers (or other low-level software such as power management) installed? –  David Schwartz Mar 27 '13 at 22:54
    
Sorry for the late reply. Small Desktop CPU, nothing too unusual, just small form factor pc's. I have disabled all power management in the Bios I could, and also tried different power management settings for the settings that I could not disable.. (You cant completely disable APM, but set it to different type.. I tried all of them. I have reverted to installing a app that syncs with timeservers every 15 minutes. Currently, this is working for me... still not sure what is causing the time stop issue. –  Louis van Tonder May 2 '13 at 8:55

1 Answer 1

up vote 0 down vote accepted

I had a similar problem using a Dell PC to display the current Weather, After contacting Dell they said there Motherboard stops the Real Time Clock when an application is running needs more processing power, this should only stop for a maximum of 5 Minutes every hour which should be acceptable to most users.

The way i temporally got around this was using Dimension 4 to synchronize the time every minute, now i am using a PCI-X Time Server card to keep the system time which works perfectly

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.