Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

With or without a specific document language, whenever "cindent" is set on vim, no comma can be typed or even pasted on the document.

I got a "non-us-standard" keyboard (pt-latin).

share|improve this question
    
Does this still happen when Vim is invoked as: vim -u NONE -U NONE --noplugin -N -c 'set cindent' –  Heptite Mar 28 '13 at 5:37
    
No. It doesn't happens when i invoke that way. Can you tell me whats wrong? –  Claudiop Mar 28 '13 at 5:56
2  
Basically what that command does is disable everything else, and sets 'cindent' on. What it means is that you probably have something in your startup files (vimrc, etc.) or plugins that is interfering. –  Heptite Mar 28 '13 at 6:07
    
There was a problem on the .vimrc, cinkeys were by mistake including the comma. Sort of duplicate of this one: askubuntu.com/questions/10662/… –  Claudiop Mar 29 '13 at 4:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.