Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have noticed that my windows 7 computer no longer activates the screensaver or enters sleep mode when left unattended. I have tried to use the command prompt to find out what is running and keeping it from going idle as suggested by others, however it tells me that "you do not have the permissions required to perform this action." However, I'm using an administrator account. I am the only user on this computer.

Help would be appreciated. Im not a tech person, so please try and keep it simple.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Double check your power settings. When plugged and when not. They are different. You will find these in power options in control panel.

Run your command prompt as administrator. Right-click on the command prompt icon > "Run as administrator". This way you should be able to run your commands without trouble.

Try with settings where the laptop will fall asleep in 5 minutes and no programs are running. If it goes to sleep then, you will figure what is halting that later. If it doesn't than you should check your power settings in the BIOS.

share|improve this answer

Required permissions:

Click on the Start button, type cmd, and when cmd.exe shows up, right click on it and click on "Run as administrator". Now you'll be seeing a command prompt with administrator rights.

enter image description here

Setting sleep options

On the Control Panel, look for "Change when the computer sleeps". On the "change settings for the plan:..." dialog, set the "Put the computer to sleep" option to a desired value (both in "on battery" and "plugged in" state).

enter image description here

Now click the "Change advanced power settings" link in the same dialog box. Click on "Sleep", click on "Allow waker timers", set it to "Disable".

Now click on "Multimedia settings", click on "When sharing media", click "Allow the computer to sleep".

enter image description here

Stoping devices from preventing sleep

On the command prompt, enter Powercfg -devicequery wake_armed. This will show a list of devices that can prevent your computer from sleeping. You can remove a device from this list by using the command Powercfg -devicedisablewake "devicename" (quotes included).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.