Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Why does the install program for PersonalBrain 5 not launch completely in Windows 7 RC1?

It always gets stuck about six sevenths of the way.

alt text

share|improve this question
    
How stuck? I mean, have you tried waiting for a few minutes, say 5? –  A Dwarf Oct 19 '09 at 17:47
    
I have waited for an hour, if nor more. I have also installed it on another computer with Vista and it went quick. –  systemovich Oct 19 '09 at 18:00
    
Okies. Posting a reply –  A Dwarf Oct 19 '09 at 18:03
add comment

1 Answer

up vote 0 down vote accepted

Many Windows 7 (and Vista, I reckon) application setup hangups can be traced back to user permissions. Usually the application fault when the last stages of the setup try to write to protected areas like "Program Files". But sometimes because of the user profile settings not allowing some type of procedure to take place.

I'm actually unsure as to why this happens. After all we are expected to either get a UAC prompt, or a permission denied prompt... or even a crash. But it just hangs sometimes. Clearly something Microsoft needs to work on in future patches.

In any case, there's a few things one can do to ensure proper installation. Or, at the very least, eliminate this possibility from the list of hangup causes:

  • You say, you install fine in Vista. Try to run the setup under Vista compatibility mode.
  • That failing, just for kicks, try to run it as Administrator.
  • That failing, tell windows whose da boss and disable UAC, reboot, and then try to install. Re-enable UAC and reboot afterwards.

If while doing any of these procedures you get a prompt telling you this application didn't install properly and asking you if you want it to install under recommended settings, unless you are sure this time it installed properly, accept installing it with the recommended settings.

This clears up the user permissions as being the problem, and instead tells you it's a compatibility issue with Windows 7. The recommended settings are a good option, because your setup will be wrapped around an even better shim than that provided by the Compatibility settings.

share|improve this answer
    
Thanks, Dwarf! Just disabling UAC did not work, so I ran in Vista (Service Pack 2) mode and it installed. Then I had to update Java too. –  systemovich Oct 19 '09 at 20:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.