Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an hp Pavilion dm4-1350en. I recently installed a 64-bit Microsoft Windows 7 Ultimate SP1, because the last one (installed by a friend) was 32-bit and made a dual boot for two options: Windows 7, and Windows 7 Loader EX.

While installing the new Windows 7, there were two hard disk partitions that I couldn't do anything with them (format, delete, etc...). However I was able to format the partition with the 32-bit version. I continued thinking that I could do this from disk management.

After the successful install, I used a driver pack DVD to install all needed drivers since I do not have the recovery disk. It installed everything successfully except for the Fingerprint Validity Sensor, which is not a problem. After the restart the laptop screen gave me the boot screens and also the dual boot problem (obviously the problem is still there) until it reached the Welcome screen, after that, nothing.
I pressed sleep, then woke it up, it worked! I went to device manager and found two display

adapters:
-AMD Radeon HD 6300M series.
-Intel(R) HD Graphics.

I disabled the intel first, the screen dimmed off, I can see a picture, but with no backlight. I fought my way until I enabled it again and disabled the AMD one, and now I can see.
Now I don't know what to do, I can't play any game such as Call of Duty 4 and Command and Conquer Generals (both give me errors), but I can play Command and Conquer Red Alert 2.

I have no idea what to do, so I came here to the experts.
Any help is appreciated, and ask for any additional information.

Thanks in advance.

share|improve this question
1  
What errors? Are they graphics related? Also, why do you need to disable the display adapter? –  Kruug Mar 28 '13 at 14:15
    
Errors are dll related like ntdll.dll (for generals) and kernelbase.dll (for CoD 4). Note that even when enabling both and the screen becomes dark, I tried to enter both, they gave me the same errors. Those are the only games I tried, if you want I can try other applications. –  mohdhamm Mar 28 '13 at 15:11
    
Anybody can help?! –  mohdhamm Mar 29 '13 at 10:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.