Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have tried all ports on my Windows Vista HE laptop, I have tried different USB mice as well. I still have a problem that when the mouse moves too fast or when the cord dangles down by putting the computer on my lap and the mouse on a side-table, it will freeze.

I occasionally even get a message that the USB device is not recognized. The fix is to pull the USB out of the port, wait for 5 sec., and plug back in until it freezes again. Initially this only gave me trouble with the mouse, but I have also noticed it with a USB connection to an mp3 player.

On occasion, I can let the computer go to the screen saver and the mouse works fine, but there is no pattern to any of this. The best pattern I can find is that I have to have my laptop sitting on a desk at all times with little movement to it (remember, ports don't matter, nor the mouse).

The issue is getting worse and before I take it to a PC specialist, I would like your opinion.

share|improve this question

closed as too localized by random Jul 28 '11 at 22:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Did you try the mouse on another computer? –  harrymc Oct 19 '09 at 16:33
    
is the laptop still under warranty? –  quack quixote Oct 19 '09 at 16:33

1 Answer 1

  • Try the mouse on another computer, and see if it does the same thing.
  • Your USB ports may be defective or shorted out - this happened to me before when someone stuck metallic conductors objects into the USB port, and when you try to attach USB devices to the port it will cause electrical damage (with wonderfully weird effects on the OS). You may have to replace the port/USB controller.
  • Try a different operating system (grab an Ubuntu LiveCD) and try it. It may be corrupted drivers/viruses/malware.
share|improve this answer