Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to perform a remote desktop connection to my Ubuntu system from Mac.

I had installed the vnc on ubuntu and trying to use Finder to connect.

The problem is I'm getting a error message:

The software on the remote computer appears to be incompatible with this version of Screen Sharing.

Somone knows how to solve this?

Info

Mac OS X 10.8.2

Ubuntu 12.04.2 LTS

Finder 10.8.1

vncserver (couldn't find it directly (no -v option available), but the man says 03 Mar 2005)

share|improve this question
    
VNC versions would be helpful as it sounds more like an application issue as opposed to the OS. You may not be able to use finder. –  hydroparadise Mar 28 '13 at 16:47
    
@hydroparadise, I'm trying to get the vncserver version, but I couldn't yet... It hasn't a -v option. Anyway the man says 03 Mar 2005. –  GarouDan Mar 28 '13 at 17:01

2 Answers 2

If you need to run only one or two applications on the Ubuntu system, then you can use ssh with '-X' option.

ssh -X user@ubuntu

Then run browser etc on the Ubuntu's command line and it will become visible on your Mac. This will allow you to run any GUI application(like firefox) remotely from the Mac system.

On a side note, to find the version of vncserver you can run:

dpkg -l vncserver

or if the above doesn't work:

dpkg -l|grep vncserver

you also need to mention version of vnc client installed on Mac.

share|improve this answer

There's a significant difference between using ssh -X or the VNC system. With VNC you get a visual copy of the desktop on the remote system at that moment the VNC server was started. With ss -X you start a new X-session; it also requires a X-Windows system on the local computer. Because a Mac is basically a *nix system, this shouldn't be a problem.

So it depends how you want to setup your remote desktop session: see what's on the remote monitor or start a new session.

When using ssh -X you should check whether X-Windows forwarding is enabled on the remote computer. Check the file /etc/ssh/ssh_config and your possible default settings for the entry ForwardX11 (it should be yes for this to work).

Then an important thing: once you are connected to the remote machine, all you have is a shell. If you want to see the desktop, start the Unity desktop (or KDE, or XFCE4) using the proper command. For instance for XFCE4 start xfce4-session

Remember that running Unity implies a lot of heavy graphics work that needs to go over the SSH-line, so perhaps you can install XFCE4 along with Unity.

Another tip: exchange SSH key for login-less SSH :) Use ssh-copy-id user@machine and follow instructions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.