Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My PC is a custom build, and since I've had it - it won't turn off, unless you use the plug.

When I click Shutdown on my Windows 7 PC, the operation is successful - the PC shuts down as expected. However, after a second or two, it'll boot back up.

I've checked the BIOS and disabled "Wake up on LAN" also disabled to functions to wake up on keyboard and such, too; regardless, my PC still won't shut down. My most common method of shutting it down (when the girlfriend wants a good nights sleep), I hit "Sleep," wait for the fans to go off, then hold the power button for a few seconds. I know this isn't safe, but it's the quickest and easiest option. My second option is to shut down the PC and normal, then when I hear it go off (the fans and lights), I hit the switch on the plug, wait about 10-15 seconds then turn it back on (I need it on because my surround sound, Mac, tablet charger and mobile charger all use the same extension lead).

I've checked everywhere, including deep in the registry for any possible solution, but I'm stuck and I give in.

Hopefully, someone will have some guidance!

share|improve this question
    
Boot a live Linux CD. Can you shutdown from there? –  terdon Mar 28 '13 at 19:03
1  
I have a second HDD in the PC specifically for Linux - that shuts down fine; Windows 7 does not. –  huzi8t9 Mar 28 '13 at 19:22
add comment

3 Answers

You can generate a report containing information about sleep/wakeup problems with the command "powercfg /energy" from an admin command prompt. This might give you information about what Wakes the machine up over and over.

share|improve this answer
    
Hey, I tried posting the results here but it's too large, so I uploaded it to my server: beta.clan-hq.co.uk/energy-report.html I don't fully understand the results, although there are 10 errors, 22 warnings and 24 "Informational" –  huzi8t9 Mar 31 '13 at 19:56
    
The report lists a number of USB devices as having problems going to sleep mode. Test shutdown without USB devices connected to identify if one of them is the cause of the problem. There could be a driver issue as it shuts down when running Linux. –  Per Salmi Apr 1 '13 at 11:41
    
Btw, di you gave SP1 for Windows 7 installed?It says build number 7600 in the report indicating that you do not have SP1. –  Per Salmi Apr 1 '13 at 11:45
add comment

I am assuming that you are connected to your router via cable.

Try this:

  1. Go to Start -> Control Panel -> System and Security and then click on the Device Manager link located under the System heading.

  2. Select Network Adapters and then right click on the name of your wired network controller and select Properties.

  3. Select the Advanced Users tab. Disable everything that says "Wake on something".

If you are connected wirelessly to your router, right click the name of your wireless network controller in step 2.

share|improve this answer
    
Possibly check the BIOS for anything that says "Wake on..." as well. –  techturtle Mar 28 '13 at 18:54
    
I've disabled everything in all network controllers that start "Wake on" - same as in the BIOS. I've just tried restarting but get the same problem :( –  huzi8t9 Mar 28 '13 at 19:22
    
Damn! Is your network driver up to date? Update to the latest version just in case this is a bug. –  Don Juan dePython Mar 28 '13 at 19:44
add comment

You've not given us much detail about your PC, specifically the Motherboard, but here are a couple things you can try to see if it resolves your issue.

  1. Update the BIOS
  2. Update all drivers for the motherboard (I've read where the self assigned drivers of Microsoft don't always work well. So, the manufacturer's are always better)

Typically these updates can be obtained from the motherboard manufacturer's web site.

This question is similar to yours but not the same, maybe the answer will help.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.