Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This actually might be a strange question to ask. It's not affecting anything but I do feel a bit awkward to see my Ethernet connection named as "Derek 2". It can be seen that there is no other networks named as "Derek" so I really want to know if there's a way for me to rename my Ethernet connection.

Screenshot of my network connections

Screenshot of Network and Sharing center

share|improve this question

3 Answers 3

up vote 2 down vote accepted

I've finally solved this problem by deleting network profiles from regedit.

Source: http://www.neowin.net/forum/topic/1101977-windows-8-rename-network/

The network profiles are stored under: HKLM\Software\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles\

share|improve this answer
    
Thank you - your answer worked but don't forget to reboot. You can also RegEdit search for "Network 2" - notice that is TWO spaces. –  Daniel Sokolowski Jul 31 '13 at 3:24

You have more than one network profile stored on your machine for the same network.

If you go to....Control Panel>>Network and Sharing Center.....under your active network you can see the icon that might look like a house or office building. Clicking on this will take you to the network properties page. From here you can rename the network or change the icon. But to keep this from happening again, you can also merge or delete network locations from this configuration box as well. You can either delete "Derek" and Derek 2"...and than rejoin your network...or just merge the two.

share|improve this answer
    
Actually I haven't seen any icon that might look like a house or office building... –  derekhh Mar 28 '13 at 21:04
    
I've added a screenshot of my network and sharing center... –  derekhh Mar 28 '13 at 21:05
    
AH, overlooked Windows 8 –  Pretzel Mar 28 '13 at 21:11
    
You can simply rename the connection under change adapter settings –  Pretzel Mar 28 '13 at 21:18
    
But again, this is because for whichever reason your machine has stored multiple profiles. So it may happen again if you were to reconnect. So this may not be a permanent solution. I have only just recently made the transition to windows 8 with one of my machines. So I will be looking for a solution like I posted abouve. –  Pretzel Mar 28 '13 at 21:32

Right-click network icon in the notification area and choose Network and Sharing Center. In the left pane, click Change adapter settings. Rename adapters there and that's it, reboot if you can't see changes instantly.

share|improve this answer
    
Does not eliminate extra network profiles or these "hidden devices" –  Pretzel Mar 28 '13 at 21:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.