Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Gnome 3 has a menu bar that includes the day of the week and the time. The date and time settings allow the time to be shown in 24 hour or AM/PM style.

There do not appear, however, to be any options for displaying the date. Instead of "Thu 1:59 PM", I'd like it to read (for example) "1:59 PM, Thursday, March 28, 2013".

How can I configure the format of the date in the menu bar?

share|improve this question
up vote 12 down vote accepted

You can use dconf-editor to change many of the settings (GSettings) on your GNOME desktop environment. For this case you need to install the dconf-tools package. Run dconf-editor and find the appropriate key for your time settings.

e.g. org.gnome.desktop.interface.clock-show-date

share|improve this answer
Too bad the nice people of Gnome didn't put this setting in the UI. It's the date I need to glance to once in a while, I usually know what day it is. – Bart Friederichs Nov 18 '13 at 8:35
Previously this was provided by the key but has changed around GNOME 3.6. This may be changed graphically using the gnome-teak-tool UI, too. – liberforce Nov 22 '13 at 16:33
@liberforce you have a typo: it is gnome-tweak-tool and thanks – mau Nov 19 '15 at 0:39

[To expand on what liberforce said]

  1. launch gnome-tweak-tool, sometimes called Advanced Settings
  2. click the Shell menu, then enable Show date in clock
share|improve this answer

The gnome-tweak-tool works (the dconf-editor does not) debian 7(wheezy) ... however now the box is too narrow to display the time ... sigh

Turns out this is a "real-estate" issue , I used to recover a small bit of space, now I can see date AND time

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .