Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Afterburner to "natively" overclock a 7950, having used the "-xcl" option. From what I understand, this bypasses the need for unofficial Afterburner overclocking, and instead unlocks the limits through Catalyst Control Center, which CCC then manages/controls.

The problem is that although I have an overclock setting of 1150mhz core clock, after a little while in-game, it drops down to around 750mhz, constantly fluctuating up and down a few mhz. I'm guessing this has something to do with AMD's PowerPlay?

I've tried closing down CCC and MOM to stop this, but it continues to happen. I have to continually alt-tab out of the game, reapply an overclock in Afterburner, alt-tab back into the game, and start playing again. But it's only a matter of time before the core clock gets clocked back down to a constantly changing core clock. I have no idea why this is happening, or what the mechanics of PowerPlay are.

How do I stop this from happening? It severely kills performance. It's done this so far in Starcraft 2, and also Far Cry 3.

(NOTE: I asked this on Gaming, but was closed and pointed here)

share|improve this question
3  
What kind of temps are you getting? It could be overheating and throttling back down... –  Breakthrough Mar 28 '13 at 23:31
    
I'm having the exact same issue as I try to overclock with MSI Afterburner and FurMark. It's like to boost clock runs for a period of time (seconds) and then it defers back to AMD Reference 900-ish MHz setting.... I don't know about OPs, but my temps are at 70c. –  Frank V Mar 29 '13 at 15:18
    
So, I switched from furmark to unigine heaven and I'm not observing the down-clock. It's holding my OC right now at 1100 and I've been benchmarking and letting it continue to run... Interestly, the temps are lower in Heaven than furmark. I'm averaging 62 in Unigine Heaven vs 71 in FurMark... –  Frank V Mar 29 '13 at 15:59
add comment

1 Answer 1

up vote 3 down vote accepted

Got it!

It was a matter of the "Power Control" setting, with the +20% boost being reported like it was fully applied, but in reality, not really registered in function.

I cut down variables, exiting out of Afterburner, and then focusing on CCC. I dropped the power control setting back down to 0%, tried to apply an overclock, and then went and played the game -- the overclock didn't apply or register at all (good).

I went back into CCC, and reapplied a +20% power control boost, and then reapplied the overclock. I went into the game and started playing. The overclock applied just fine, and best of all -- it held out! It's been going strong now since, with no reversions or downclockings.

I guess it's some bug in either Afterburner, CCC, or drivers, with the "power control" boost not actually getting applied, even though it's reported that it is. I guess I'll just have to manage by manually reapplying the boost every time my machine boots up.

(For reference, I've been using the "native" overclocking option through Afterburner, using the "-xcl" switch, which apparently unlocks the CCC overclock limits, and controls the overclock "natively" through that way, rather than messing around with any unofficial overclocking mumbo-jumbo.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.