Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to setup a small home server using Fedora 17 (32 Bit) and No-ip because I have a Dynamic IP adress,

This is what am I doing:

1) I create a Host on No-ip:

image description

2) I setup No-ip on my fedora box:

su -
yum install noip
noip2 -C
chkconfig noip --add
chkconfig --levels 35 noip on

NOTE: My no-ip config file it's located at: /etc/no-ip2.conf

Reboot and verify it is running:

su -
service noip status
chkconfig --list | grep noip
host myserver.servebeer.com

(it actually points to my public IP adress)

3) Open Ports on the fedora's firewall:

image description

image description

4) Unlock No-IP on iptables:

su -
iptables -A INPUT -s dynupdate.no-ip.com -p tcp --sport 8243 -j ACCEPT
iptables -A OUTPUT -d dynupdate.no-ip.com -p tcp --dport 8243 -j ACCEPT
service iptables stop
service iptables start
service noip stop
service noip start
service noip status

5) Port Fowarding on the router:

image description

(I get the private IP adress from ifconfig)

6) Verify with zenmap, telnet & ping

image description

NOTE: Here we have an interesting situation: Only the 80 TCP port seems to be open, the other two (111, 8243) are closed, even when they are unlocked on the firewall and forwarded on the router.

image description

PING fails, but as far as I know this is kinda normal right? 'cause ping isn't a DNS test mechanism... Correct me if I'm wrong please:

image description

Additional info:

I have an Apache/PHP setup, so if I go to **http://127.0.0.1/test.php** I see my test.php page, but if I go to http://myserver.servebeer.com or http://myserver.servebeer.com/test.php I can't see anything, the browser just tries and tries and then throws an error...

P.S. SELinux is fully Disabled

What am I doing wrong? Please Help me!

share|improve this question
    
Does your ISP allow you to host your own server? Don't assume they do. In most cases, ISPs will not allow port 80 traffic in this manner. For test purposes, try setting up your server using port 81 instead (or port 8080, or whatever you like), and when you attempt to connect to it from the outside, remember to add the :81 (or :8080 or whatever port you chose) to the end of the address. See if that works. You know.. myserver.servebeer.com:81 just as an example –  Bon Gart Mar 29 '13 at 16:08
    
When I configure no-ip, I must start a cron job to force the noip service every 5 hours ( fclose.com/4677/how-to-install-noip2-on-linux ) -- to capture the latest dynamical IP. –  ericzma Aug 22 '13 at 9:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.