Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to remote display Java based development environments, such as NetBeans and IntelliJ, from a linux machine to a windows machine. When I do this, the right click functionality of the environments does not work, which makes them unusable.

I use the -X option with Putty to tunnel X through SSH. I've repeated this using Ubuntu and RedHat to my Windows running Xming. Is there a trick to remote Xing java applications that I'm missing?

share|improve this question
    
my first guess is a misconfiguration in your local X server, since that's getting the click events first. can you connect to the linux box (eg, via VLC) and see the right-click working there? –  quack quixote Oct 19 '09 at 17:10
    
Yes, right click works on Linux –  nathan Oct 19 '09 at 17:14
    
are you starting Xming with the -multiwindow option? –  quack quixote Oct 19 '09 at 17:29
    
The -multiwindow allowed me access to the right click and file menu, but only until I move the window. Once the java application's window is moved, then there is no way to left or right click menu items on the application. –  nathan Oct 20 '09 at 12:50

4 Answers 4

up vote 3 down vote accepted

From this post on the java.net forums it seems that there are "incorrect insets detection when using the Xming". The fix is to set the AWT_TOOLKIT environment variable. Explanation for why can be found on Sun's page here.

AWT_TOOLKIT=MToolkit

Setting this environment variable fixed all problems.

share|improve this answer
    
the quote from the forum is "incorrect insets detection when using the Xming", which doesn't necessarily imply it's Xming doing the incorrect detection. sounds like it's a bug in Swing. good job finding the workaround, +1! –  quack quixote Oct 20 '09 at 14:07
    
Good point. I'll correct my quote and reword to not put Xming at fault. –  nathan Oct 20 '09 at 14:24
    
So, this seemed to solve the problem for a while for me too, however, I'm now faced with another problem, I sometimes get some sort of keyboard focus/event problem, I can't type in my textboxes and such until i change the focuse to another window and back... anyone run into this ? –  Nico Jun 29 '10 at 15:52

It seems the problem with events is still in place. I may not access menu in SQLDeveloper running on Linux and Xming on Windows. It happens if window is moved, so it loses the focus on Menu options. It may be activated using mouse however keyboard must be used

share|improve this answer

I also had errors in our Solaris 11 server to Windows 7 desktop using Xming. We were installing some Oracle (Java) apps on the Solaris 11 server and we had issues with XMing with input field becoming uneditable at random times. We tried so many parameter changes and nothing worked (not even a corporate license of Exceed, but that was another issue). We tried using MobaXterm and that worked well and allowed us to do our Oracle installs without issue.

share|improve this answer

Have you tried this other XServer tool?

http://mobaxterm.mobatek.net/

I used to have issues with XMing, this one is not only faster, but solved some of those issues for me (input field becoming uneditable among them).

I'm using the free 6.2 portable version. Make sure you start your session from inside the GUI, this way you don't even have to export the display.

I hope this helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.