Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an install of IE8 that doesn't have the compatibility view button next to the url bar. I vaguely remember during install that there was a question about whether it was to be available or not, I may have clicked no. Or maybe that was a dream. There are no options that I can see about it being available or not. Anyone know how to enable it? I'm about to try re-install but I'm hoping I can fix it without re-installing.

Version: 8.0.6001.18702 ; Update Versions: 0

share|improve this question

3 Answers 3

up vote 4 down vote accepted

1) If you right-click on the toolbars somewhere, you should have a menu with an option saying Compatibility View Button. Select it.

2) Under the Page menu (and also the Tools menu) there's a option called Compatibility View Settings. I believe that option on the install relates to whether you get updates or not to it, in which case the top checkbox on the setting screen is ticked. By default, I think just the Intranet-related one is.

share|improve this answer

During the install there is an option to get a list of sites that are known to be incompatible with IE8 right now, and get forced into 'IE7 mode'. They option can be re-enabled by going to tools->compatibility view settings and checking the box for 'Include updated websites ...'

Now, if you are not seeing the button next to the address bar, there could be a couple of reasons.

  1. You are hiding the button Right click an empty spot on the tab row, and see if 'Compatibility View Button' is checked

  2. Some websites do not need to show the compatibility view button because they are sending the browser an extra flag called x-ua-compatible. When a website specifically opts into compatibility, then IE8 does not show the compatibility button.

share|improve this answer
    
Stupid x-ua-compatible meta tag! Thx mbenny, that helped me! –  WooYek Jan 27 '11 at 16:46
    

Un-check following options in Tools-> Compatibility view Settings

  1. Display intranet sites in Compatibility view

  2. Display all websites in compatibility view

Refresh the page and see if the compatibility view icon appears near the url

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.