Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a physical path named: c:\user\ajma\Documents but when I look at it in explorer, it keeps showing up as "My Documents". Does anyone know where the setting is to make it display "Documents"? (same thing for "My Music", "My Videos", etc...)

I'm on a domain so I'm assuming it's a group policy of some kind. (I'm using Win7 as my client) I want to change it so that all users show "Documents" instead of "My Documents".

share|improve this question
    
I just checked the group policy for Server 2008 R2 (which has all of the policies available to Windows 7) and there are no mentions of renaming the folder using desktop.ini in there at all. –  Joshua Oct 19 '09 at 20:53

1 Answer 1

up vote 6 down vote accepted

You can just rename it and it'll show the new display name. Renaming through explorer will not rename the actual folder.

More information:
The directory name is Documents, if you look inside of it you'll see a hidden desktop.ini folder. Explorer is using the name from inside the desktop.ini and displaying that instead of the actual folder name.

If you look inside the desktop.ini you should see lines similar to the following:

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21770
IconResource=%SystemRoot%\system32\imageres.dll,-112
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-235

If you remove the LocalizedResourceName from the ini file and logoff and log back on the name will be whatever the folder name is.

I believe the simplest way to take care of this domain wide would be to write a user login script that copied over a new desktop.ini per folder you wanted to change (since the different folders have different icon resources you can't use the same for all) and drop a marker file to indicate you've processed this user. The marker file would prevent the script from running at each logon and allow the user to change it if the desire.

Example logon script (not tested):

@echo off
set MARKERFILE=%APPDATA%\desktopscript.dat
if exist "%MARKERFILE%" goto eof

copy \\server\share\documents.ini "%USERPROFILE%\Documents\Desktop.ini" /y
copy \\server\share\music.ini "%USERPROFILE%\Music\Desktop.ini" /y
copy \\server\share\pictures.ini "%USERPROFILE%\Pictures\Desktop.ini" /y
::etc.

echo > "%MARKERFILE%"
share|improve this answer
    
Where did desktop.ini get set? When I did a clean install, it was named properly first. When I joined it to the domain, it got renamed to "My Documents", so what I'm looking for is the setting that's causing it to get renamed like this. If I change the desktop.ini, it's not going to fix it for all users and I don't want to have to update each computer one-by-one. –  ajma Oct 19 '09 at 20:34
    
I don't have a non domain joined Windows 7 here with me to check but in every install I've seen it has been My this and My that (I personally prefer the Vista way of naming them. –  Joshua Oct 19 '09 at 20:37
    
You're right. I just did a clean win7 install (non-domain joined) and it says "My Documents". –  ajma Oct 20 '09 at 3:44
    
You can use the same approach (removing LocalizedResourceName from Desktop.ini) for your default Picture (and other similar) folder. –  Richard Oct 21 '09 at 21:18
    
@ajma: I believe the name gets set when a folder is designated as your default Documents, Pictures, ... folder. –  Richard Oct 21 '09 at 21:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.