Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an e2500 and a macbook pro early 2011 bonded with it at 300 Mbps.

My Comcast internet connection is 50+ Mbps via ethernet but only 25-26 Mbps via Wireless-N.

When my wireless router is set to bridge mode (and my laptop gets a public IP), the wireless internet speed goes up to 34Mbps. This mode isn't ideal since mMy SB 6121 cablemodem doesn't have routing capabilities.

So I plugged another laptop via ethernet and, using iPerf, tested my Wireless-N connection to that laptop. It climbed almost to 100Mbps. Now that's more like it! This rules out any radio issues.

I am baffled by this issue so hopefully, someone will have encountered it before. How can I keep this speed when I'm downloading from the internet? Why did setting my E2500 router to bridge mode make a difference?

Any help would be appreciated!

share|improve this question

2 Answers 2

Thats a nutty one, but you are not the only one experiencing it. Look here. I'd posit the problem is a combination of the hardware design and firmware, with the speed of operations in forwarding packets interfering with the timing of the WIFI or similar.

It could also be that the router is working perfectly, and that when it was in bridge mode it did not share the connection with other devices, so fewer WIFI collisions and better throughput.

You may also be able to get better WIFI performance by tweeking your settings, for example "short preamble", turning your encryption off (not necessarily wise, but can result in a substantial speed increase), changing channel. Also, if you are using 20MHZ channels, change to 40MHZ ones - this will make a vast difference in throughput as it has twice the bandwidth available.

share|improve this answer
up vote 0 down vote accepted

I found my solution here, courtesy of ScarletJamie. Disabling WMM under the QoS section in Applications and Gaming did the trick beautifully. Cisco/linksys botched their QoS algorithm terribly or didn't optimize it for 25 Mbps+ connections.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.