Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using the latest version of Kubuntu and need to use nm-applet instead of knetworkmanager due to access issues with my work VPN and also seem to have issues with knetworkmanager forgetting how to connect to wifi (but that's another question altogether). I have installed all the needed packages to run nm-applet (the default Gnome network manager applet that comes in the network-manager-gnome package). Each time I reboot my machine I have to follow these steps:

  1. open terminal and execute: killall knetworkmanager
  2. launch Krunner and run nm-applet
  3. all runs as expected

I'd like to be able to just setup my environment to not launch knetworkmanager and instead launch nm-applet at startup.

How is this accomplished?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Here is what I do to achieve the behavior you want :

  • Do the steps you do describe in your post (kill knetworkmanager and start nm-applet)
  • You should then edit this file

/etc/xdg/autostart/nm-applet.desktop

[Desktop Entry]
Name=Network Manager
Comment=Control your network connections
Icon=nm-device-wireless
Exec=nm-applet --sm-disable
Terminal=false
Type=Application
OnlyShowIn=KDE;
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=NetworkManager
X-GNOME-Bugzilla-Component=general
X-GNOME-Autostart-enabled=true
X-Ubuntu-Gettext-Domain=nm-applet
  • Make sure OnlyShowIn contains KDE
  • Uninstall the plasma-widget-network-manager since you are using the gnome applet instead
  • The gnome applet should be executed automatically after a reboot

I am doing this since kubuntu 7.04 because I cannot connect to my company VPN with knetworkmanager using the PPTP plugin. I hope some day I won't need this fix.

share|improve this answer
add comment

I don't use KDE, but I expect it's the same basic process. You want to remove knetworkmanager from the list of programs started at the beginning of your Session.

Here's instructions for using KDE's Session Manager to set a manually-saved session as the default:

  1. Open K-Menu > Control Center > KDE Components > Session Manager
  2. Select Restore manually saved session. This will cause a Save Session button to appear on the K-Menu. (See the link for a description of the other options.)
  3. Open all the applications you want started when you login to KDE; close any running applications you don't want started.
  4. Open K-Menu > Save Session
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.