Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have no issues using my iphone or other devices that are wirelessly connected to the same network, however my Windows 7 machine is unable to resolve the url.

For example:

ping www.google.ca results in a timeout but pinging the same IP address directly, works fine.
I can also use IP addresses in the browser and that also works.
There is nothing wrong with the DNS server being used (default from my provider) as my other devices that are also connected via WiFi without any further customizations of proxies.

I have tried rebooting the router
I have tried rebooting the Window 7 box(which seems to be default fix for Windows issues)
I have tried ipconfig /renew, nothing..

Here is the content of ipconfig /all

C:\Windows\system32>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : nelson-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Broadcast
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : home

Ethernet adapter Local Area Connection 3:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : TAP-Win32 Adapter V9
   Physical Address. . . . . . . . . : 00-FF-0C-A5-F2-7B
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . : home
   Description . . . . . . . . . . . : Dell Wireless 1397 WLAN Mini-Card
   Physical Address. . . . . . . . . : 70-1A-04-C5-4F-36
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::f5a6:68ff:2444:8611%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.2.10(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : March-29-13 6:08:06 AM
   Lease Expires . . . . . . . . . . : April-01-13 7:11:12 AM
   Default Gateway . . . . . . . . . : 192.168.2.1
   DHCP Server . . . . . . . . . . . : 192.168.2.1
   DHCPv6 IAID . . . . . . . . . . . : 225450500
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-A6-44-56-A4-BA-DB-9E-D9-2C

   DNS Servers . . . . . . . . . . . : 10.8.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : home
   Description . . . . . . . . . . . : Marvell Yukon 88E8040 PCI-E Fast Ethernet Controller
   Physical Address. . . . . . . . . : A4-BA-DB-9E-D9-2C
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{0CA5F27B-202E-4F57-9AE1-C5C859EB816A}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.home:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : home
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Other Diagnostics

C:\Windows\system32>tracert google.ca
Unable to resolve target system name google.ca.

using the ip address instead

C:\Windows\system32>tracert 173.194.75.94

Tracing route to 173.194.75.94 over a maximum of 30 hops

  1     2 ms     2 ms     1 ms  GATEWAY [192.168.2.1]
  2    13 ms    13 ms    14 ms  64.230.200.230
 ... and so on...


C:\Windows\system32>nslookup.exe
DNS request timed out.
    timeout was 2 seconds.
Default Server:  UnKnown
Address:  10.8.0.1

Any suggestions? It seems to me that I need to do something on Windows to unblock this. I have already disable the Windows Firewall (the only one that is installed). Anything else I can check?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

The address for the DNS server appears to be on a private network, have you set it manually? Most home routers would set it to the router in your case 192.168.2.1. Personally I prefer to use opendns you can get their addresses from the bottom of their home page.

share|improve this answer
    
I just came back here to post a new finding which is in line with that 'Col' just replied with. I have recently installed a VPN (mullvad) and when the VPN is enabled, my issue is resolved, however when I disable the VPN it doesn't seem to clean up after itself properly. I have contacted mullvad folks, hopefully they can help remedy this. –  user212457 Mar 29 '13 at 12:05
    
Sounds like they've changed you to manual DNS on your wireless adapter to the DNS server for the vpn. If you set it back to automatic or change it to the opendns ones it should work while not on the vpn it may break the vpn. –  Col Mar 29 '13 at 12:13
    
Yep, that is exactly what has happened. I wonder if there is some automated way of doing this.. I guess I will run some tests! Thanks for your help!!!!!! –  user212457 Mar 29 '13 at 12:19
    
Have a look at the netsh command, I think that might let you do it. –  Col Mar 29 '13 at 12:30
    
Thanks! You are awesome!! It seems to be working correctly now. I can surf with or without the VPN. I will look in to the netsh next, but all I did was set the DNS to be automatic and both modes works fine. I did a quick checkmyip test and both modes seem to be working fine. –  user212457 Mar 29 '13 at 12:32

Your network card is set to this IP: 192.168.2.1
Your DNS server is at 10.8.0.1

Those are RFC 1918 addresses.

Normal public IPs are supposed to be routed on the Internet. RFC 1918 addresses are supposed to be used internally and never ever reach the public Internet. Many routers are sensibly programmed not to route them.

Thus this will not work, unless unless you have at least two networks at home:

  • Network the 192.168.2.x (assuming /24)
  • and network 10.8.0.x (also traditional the /24's)
  • And your home router has entries in the routing tables for these two.

If you are trying to use a nameserver from somewhere else, that nameserver needs to:

  • Either be publicly reachable (Not using a RFC 1918 address, but a normal public IP)
  • Or you need a tunnel or a VPN to that network.


To confirm this is a problem:

  1. Try reaching the server at 10.8.0.1.
    The traditional command to test this is ping 10.8.0.1. It is not the only way to test and some weirdos block ICMP echo request out of outdated worm protection idea. (Outdated since it no longer works. Worms coder have adapted to that).
    Keypojnt is that if you can not reach it then you can not use it to resolve DNS queries either.
  2. Try another nameserver (8.8.8.8 is a publicly available nameserver, test with that).

If neither of those work, try adding the routing table from your network (not the PC, the router) to the OP.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.