Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Ubuntu 12 from a USB drive and after the installation my laptop did not boot from the HDD anymore. Before the Ubuntu installation Win7 was installed. During the installation I choose to delete the Windows installation. I searched here (SU) and on the web and ended up in this guide.

This is the screen in the first place of the partition manager with out making any changes. First

from the size of the partitions I can say that "/dev/mapper/ubuntu-root" was the "C" partition in Windows and "/dev/sda" was the "D" partition.

and this is the screenshot. I could manage and tried to make it similar to the guide. Changed

but it did not do anything. I can not delete the partitions using the manager. I can only change the type and mount info.

Thanks for your help.

share|improve this question
    
If you don't need an encrypted partition, how about just trying a standard ubuntu install first to ensure everything CAN work. THEN go for the other crazyness. I've done 40+ ubuntu installs and that guide confuses ME. –  Chris K Mar 29 '13 at 22:59
    
yes that what I tried in the first place no encryption option was selected and just keep clicking the continue button that s all. it just did not boot from the HDD. I think, I need some fdisk stuff in the installation but have no idea how to do that. –  Onur TOPAL Mar 29 '13 at 23:12
1  
Yes, that's why I suggest starting over with the USB installer. –  Chris K Mar 29 '13 at 23:15
    
I tried to install it again and no change. Just follow the installations step choose Erase ubuntu already installed version and did not select to Load LVM just install directly and the result is the same. not booting from HDD. –  Onur TOPAL Mar 30 '13 at 23:34
    
I suspect your hardware may need extra tricks to get working. Google for ubuntu install [your laptop model] and try to see what others are doing. And good luck if your laptop is the new UEFI configuration. I've done 3 and all three were somewhat annoying to get Ubuntu to boot afterwards (similar to your situation). –  Chris K Mar 31 '13 at 23:43

1 Answer 1

up vote 0 down vote accepted

Finally it is done. I think the problem was GPT (GUID Partition Table) I just learnt just a thing exists.

So I used Gparted Live USB using this guide deleted all the disks and under the Device menu there is "Create Partition Table" which uses msdos type.

And after these steps I just set my BIOS to default settings and install the Ubuntu as usual.

To be honest I am not sure which step is actually fixed the problem but now I have working Ubuntu laptop.

Hope this helps other people as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.