Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm in some un-named country and I connected to my SOCKS 5 Proxy via an SSH Tunnel which is located in the US. I tried to visit facebook via the browser, but it just times out. But when I ping facebook via the putty terminal i get a reply. I'm not even using the standard 22 port.

I tried connecting to facebook again using the same setup, but this time I'm in South Korea and it connects fine. So it's definitely some firewall blocking my request.

How does this Anonying Firewall see what I'm requesting when im connected via a SSH Tunnel using putty?

share|improve this question

migrated from Mar 29 '13 at 22:39

This question came from our site for professional and enthusiast programmers.

Did it pop up a notice about a host key changing or similar ? I know that (at least China) has done man-in-the-middle attacks on some ssh traffic for quite some years. – davidgo Mar 29 '13 at 23:55

It's probably using local DNS instead of doing the name lookup through the proxy. Your client setting may vary.

I know that Firefox can be adjusted in about:config with the value network.proxy.socks_remote_dns - true to do name lookups through the proxy, false to use whatever DNS is configured locally.

Other browsers may or may not have an option.

share|improve this answer
i configured my socks 5 proxy in Opera 12. Any ideas of what i need to look for? – duckx Mar 30 '13 at 13:56
I googled "opera browser proxy remote dns", and see a lot of forum threads crying about lack of remote DNS in Opera with SOCKS. Best bet is to switch browsers or get a socksifier. It's been a while since I tried using a socksifier, but it was always shaky; I consistently got better results with programs that actually support proxying internally. I think you'll have a better overall experience if you switch browsers. – Jason Sherman Apr 6 '13 at 0:47
still issues with firefox with proxy setup too. – duckx Apr 6 '13 at 22:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .