Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've gotten myself into a pickle it seems. I just got the latest gentoo kernel (3.7.10), and it seems that they didn't include my wireless lan driver in the menuconfig (or it depends on another option to become visible or something). Anyway, here is what I know:

  • The driver/firmware I need is ipw2200
  • Doing a search in menuconfig (with '/') for "ipw2200" reveals that it is available:

    Symbol: IPW2200 [=n]
    Type  : tristate
    Prompt: Intel PRO/Wireless 2200BG and 2915ABG Network Connection
      Defined at drivers/net/wireless/ipw2x00/Kconfig:66
      Depends on: NETDEVICES [=y] && WLAN [=y] && PCI [=y] && CFG80211 [=y] && CFG80211_WEXT [=n]
      Location:
        -> Device Drivers
          -> Network device support (NETDEVICES [=y])
            -> Wireless LAN (WLAN [=y])
              -> Intel PRO/Wireless 2200BG and 2915ABG Network Connection (IPW2200 [=n])
    
  • I can't find it there.

Is there any way I can manually set the variable to [=m] in a config file or something? Any help would be greatly appreciated!!! Thank you!

share|improve this question

migrated from stackoverflow.com Mar 29 '13 at 23:51

This question came from our site for professional and enthusiast programmers.

    
That's a SuperUser question. Someone should move it there. In any case, please also post the dependencies. It seems some of them are not satisfied, and this is why you can't select this option. Do not try to set it manually, or stuff will BREAK. –  Ionic Mar 29 '13 at 17:26
    
Sorry man, should I ask on there, or wait for a mod o move it? Also, all the dependencies were satisfied, but ill post them on here for reassurance. Thank you. –  Athan Clark Mar 29 '13 at 19:25
    
There are only three dependencies in Kconfig, but why do you have the last dependency as "CFG80211_WEXT [=n]"? –  sawdust Mar 29 '13 at 22:21

1 Answer 1

up vote 0 down vote accepted

If you are configuring your own kernel, check that the dependencies are set right. They are probably scattered all over make menuconfig. Perhaps make xconfig (or some of the other GUIish configuraton options) is nicer to handle here.

A very dirty way out is just editing the .config file, looking for CONFIG_NETDEVICES and the others, and edit them to match what the dependency line you cite says. After that, run make oldconfig (that should clean up any tangles you created; note carefully what it asks you and compare original/edited/fixed files afterwards to make sure, might also check with make menuconfig).

If it breaks, you get to keep both pieces. Good luck!

share|improve this answer
    
You're the man! Thank you!!! –  Athan Clark Apr 1 '13 at 0:40
    
The superuser way of saying "Thanks" is to just accept and upvote the answer. And you are wellcome. –  vonbrand Apr 1 '13 at 1:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.