Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I executed

sudo chown -R USER /usr/bin

Now, when I try to "sudo" anything, I get

sudo: effective uid is not 0, is sudo installed setuid root?

I tried

pkexec chown root:root /usr/bin/sudo

and I got

pkexec: must be setuid root

I tried


and put in my password, but su won't accept it.

How can I fix this?

share|improve this question
Ubuntu doesn't have root account by default. Your password is not root's password, so it won't accept it. – terdon Mar 30 '13 at 0:20

2 Answers 2


  1. Restart your computer.

  2. When the BIOS's POST is about to vanish, hold down Shift until the GRUB menu appears.

  3. Select Advanded Options for Ubuntu, then *Ubuntu, with Linux ... (recovery mode).

  4. When the next screen appears, select root to enter single user mode.

  5. Your now logged in as root, so you'll be able to execute

    chown -R root:root /usr/bin
  6. Initiate a reboot by executing

    shutdown -r now
  7. Select resume.

share|improve this answer
NOTE: For security reasons, chown generally undoes the set-uid and set-gid bits on files and directories. So you'd have to go through and check all of these programs as well! Thus best approach is a either a proper reinstall or a restore from one of your fine backups that were previously taken. – mdpc Mar 30 '13 at 6:03

type usermod -o -u 0 "usernname" with root. So, "username" can do anything. Works fine too.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.