Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Firefox bookmark with tags www.processing.org/

I see a gold star in the address bar indicating that the url is boomarked.

However when I key in the URL processing.org (without the WWW) the bookmark icon does not show up.

Essentially both open up the same page. My question is why can't firefox figure it out? Is there a settings change I need to do?

With bookmark icon without book mark icon

share|improve this question

migrated from webapps.stackexchange.com Mar 30 '13 at 6:14

This question came from our site for power users of web applications.

    
What he said. Note that www is not a keyword, it has no special meaning other than that it (usually) goes to the home directory, by convention rather than by mandate. –  Mr Lister Nov 16 at 10:03

1 Answer 1

up vote 10 down vote accepted

Well, they are technically different URL's. It's possible to have www.processing.org and processing.org point to different locations/servers/web sites. From a usability standpoint it wouldn't make any sense to do that, but it's not impossible.

I would guess they chose the safe route and designed the bookmarks to be completely dumb in order to accommodate any not-so-intelligently designed web sites. They make no other assumptions other than "does this URL string match this URL string?" Bookmarks won't even match a sub-directory under the same domain (ex: http://processing.org/banana).

If there are settings tucked away in about:config to enable a more intelligent Bookmark URL checking system, I can't find them. You might try looking for a relevant add-on.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.