Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After running pacman -Syu today on my Arch Linux x64 system, I discovered that the icons in many of the applications were showing the image not found icon. This only seems to be in toolbars and in certain applications. For instance, in nautilus, the file icons show up fine, it's only the toolbar icons that show the image not found icon. Other applications like Firefox and gedit look normal.

  • I have tried running gtk-update-icon-cache as both myself, and root.
  • I've verified all of the icons are in /usr/share/icons
  • I have tried switching between different icon themes
  • I tried re-installing nautilus
  • Tried switching to gnome-shell, and gnome-fallback (normally run compiz + emerald)
  • Read completely through pacman.log to make sure there was no configuration files I missed.
  • Tried rebooting

I'm out of ideas. Anyone know how to fix this?

enter image description here enter image description here enter image description here

share|improve this question

1 Answer 1

up vote 3 down vote accepted

I have no idea why this worked, but I finally fixed the problem by uninstalling librsvg (without removing dependencies) and re-installing it... All of my icons are back to normal now.

sudo pacman -Rdd librsvg
sudo pacman -S librsvg

Answer was found here https://bbs.archlinux.org/viewtopic.php?id=136732

share|improve this answer
    
+1 for well explained and detailed command lines. –  Lorenzo Von Matterhorn Mar 30 '13 at 21:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.