Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am new to vagrant and I'm trying to follow a tutorial I found online for setting up an open-source web application. I have installed vagrant successfully. My problem is that when I try to run the command

vagrant gem install "anything"

I get the error

Usage: vagrant [-v] [-h] command [<args>]

    -v, --version                    Print the version and exit.
    -h, --help                       Print this help.

Available subcommands:
     box
     destroy
     halt
     init
     package
     plugin
     provision
     reload
     resume
     ssh
     ssh-config
     status
     suspend
     up

For help on any individual command run `vagrant COMMAND -h`

What the heck is going on?

share|improve this question
    
You got it all wrong, gem install is a ruby command. Vagrant is a VM management utility. –  Radoo Mar 30 '13 at 12:05
    
@Radoo - actually, if you go out and look, you'll find that much of the documentation, and many of the tutorials out there indicate that "vagrant gem install" should be valid. If I'm reading correctly, whether this is valid or not may vary depending on how Vagrant itself was installed, oddly enough. –  jwismar May 17 '13 at 0:52
add comment

1 Answer

I struggled with that as well. Just use:

vagrant plugin install any-plugin
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.