Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a bit of a problem. I am running Ubuntu 10.04 LTS on my laptop, and about 2 years ago I replaced the aging HDD with a 32 GB SSD. Today I tried to boot my computer, but it couldn't.

So I've put the SSD into an external HDD rack and booted a live CD Ubuntu 10.10 to try to recover data from the SSD. The SSD appears in the drop down menu but it won't mount.

Log:

ubuntu@ubuntu:~$ dmesg | tail
[ 2125.445659] sd 8:0:0:0: [sda] 62533296 512-byte logical blocks: (32.0 GB/29.8 GiB)
[ 2125.446983] sd 8:0:0:0: [sda] Write Protect is off
[ 2125.446988] sd 8:0:0:0: [sda] Mode Sense: 17 00 00 08
[ 2125.446992] sd 8:0:0:0: [sda] Assuming drive cache: write through
[ 2125.449084] sd 8:0:0:0: [sda] Assuming drive cache: write through
[ 2125.449098]  sda: sda1 sda2 < sda5 >
[ 2125.454285] sd 8:0:0:0: [sda] Assuming drive cache: write through
[ 2125.454293] sd 8:0:0:0: [sda] Attached SCSI disk
[ 2125.777836] JBD: no valid journal superblock found
[ 2125.777840] EXT4-fs (sda1): error loading journal

Is there a way to fix this so I can recover my data?

share|improve this question

2 Answers 2

Have you tried running fsck on it?

From the live boot, try something like:

fsck.ext4 -Dcfy -C 0 /dev/sdX#

That will:

-D - Optimize directories
-c - Check for bad sectors
-f - Force a check
-y - Assumes 'yes' to all questions
-C 0 - Prints info to stdout

You would just need to make sure, without mounting I believe, that you run it on X (the SSD) and each partition (only do EXT4 partitions).

That should fix system known issues, report back if you don't mind and I can update if I find other options.


Also found a link talking about the 'superblock' that may be worth checking though I am not familiar with this, but it uses similar commands:

sudo fsck,ext4 -v /dev/sdX

Output for a bad superblock should look like:

fsck /dev/sda5
fsck 1.41.4 (27-Jan-2009)
e2fsck 1.41.4 (27-Jan-2009)
fsck.ext4: **Group descriptors look bad**... trying backup blocks...
fsck.ext4: Bad magic number in super-block while trying to open /dev/sda5

The superblock could not be read or does not describe a correct ext4
filesystem.  If the device is valid and it really contains an ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

Then check for location of superblock backups:

sudo mke2fs -n /dev/sdX

It should tell you the superblock backups are stored on blocks: # # #

Finally restore the backups (if they exist):

sudo e2fsck -b block_number /dev/sdX

Again, I haven't tried this and cannot speak to it's validity - hopefully someone else may know a bit more about this method. Source

share|improve this answer

I regret wasting your time by posting this.. I tried those commands (probably did it wrong) but it still couldn't mount.

sudo fsck.ext4 -n /dev/sda1

Tried my luck one more time, taken out all peripherals (SD card, USB Wifi) and put the SSD back into laptop and it decided to work (!?). So after backup new clean install and I can't tell what was wrong anymore.

Thank you very much for trying to help on such a short notice.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.