Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I added the IIS role to my Windows 2003 server for a client that is running ASP. They have a default.aspx page in the site they sent me. I added a site and gave it a path of C:\Inetpub\wwwroot\_client_site

When I try to browse to it at http://my_public_ip/_client_site I am getting the error This page cannot be found.

I went into the site properties and made sure that default.aspx was the first entry for default content pages. Anonymous access is turned on and Read/Write/Directory Browsing are checked off. I also checked the folder on the file system to make surethatIUSR_Client` has read/write/list folder permissions.

What things can I look for to fix this?

share|improve this question

closed as too localized by random Jul 13 '12 at 21:06

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

This could be a number of things. If I was you, start easy and do not go head first in to asp.net

Create a new file called default.htm and just put the following in it:

<html><body>Hello World</body></html>

Next save it in to the directory and try again to visit http://your.ip.address/default.htm

if you are getting page cannot be displayed this is most likely down to a routing / firewall / networking issue. If you are seeing the hello world, we need to move on to diagnosing ASP.Net IIS errors.

If this has failed, check that the IIS service has started, The actual website has started and it is bound and listening to all ips, next try http://localhost from the server itself.

Please comment on any problems and I will try to help further.

share|improve this answer
    
@Wil - When I do the simple HTML page, and hit the IP it asks me to log-in. I set anonymous access I thought and I know the wwwroot folder allows IUSR-Client to read and list contents. –  jason Oct 20 '09 at 0:08
    
@Will - ok, I turned off all other sites, just enabled the default website, created a page in wwwroot called default.htm and hit my IP and I get a directory listing now vs the page being served. –  jason Oct 20 '09 at 0:16
    
@Will - OK works now after IIS restart. I get the default.htm page. When I try to hit my.ip/_client_site I get an error 'you are not authorized to view this page' –  jason Oct 20 '09 at 0:19
    
ok, what you need to do is go to the default documents section and simply add the file to it or rename it, I am always getting it wrong off the top of my head, it is usually a combination of - default / index then .htm or .html, anyway, this is good that it is all working. The page cannot be displayed on asp.net applications is usually for security, when you have confirmed that the site is actually working, you need to enable remote debugging so you can see the errors and what is going on. –  William Hilsum Oct 20 '09 at 0:20
    
you posted your last one before I did my last comment... Anyway, it sounds to me like a bog standard permission issue. Go to the folder holding _client_site and manually reapply the permissions and/or set inheritance. They can get lost if moving the folder from another machine. Next, through IIS itself, go to directory view and just double check the permissions there. –  William Hilsum Oct 20 '09 at 0:22

Are you sure you assigned it a new IP? It's probably looking in your Default site or another site that exists, which is responding on the same IP address. You have a few options:

  • Bind an additional IP to the NIC and assign it to that site
  • Stop your default site from responding on the same IP, maybe assign it a different port value on the same IP
  • Implement host headers
  • Disable the default website if you don't need it, or other sites that are using the IP.
  • Make your new site respond on a different port besides 80, then make a DNS entry for it pointing to the IP and port.
share|improve this answer
    
@John - The default site is disabled and the site I created uses the IP of the server. Can you only host one site per IP? Is there a virtual host concept like in Apache? –  jason Oct 20 '09 at 0:12
    
Yes there is a virtual host concept. If you want multiple sites on one IP, you must use different ports or host headers. –  John T Oct 20 '09 at 2:12