Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed backtrack 5 and I am unable to detect my wireless card. iwconfig doesn't list my interface. I can see that the hardware is present in lspci -vnn (see below) but I can't get the interface detected. I have tried to reinstall the compat-wireless package but I get errors during the build (see below) I have done a ton of researching and I keep hitting a brick wall, mostly because the wiki for backtrack is down and I can't find any good resources. Does anyone know how to fix the issue? Also, does anyone no how I can scan the hardware to determine what NIC is assigning my interface? If I can figure out the interface name I think I can set it up manually by putting up the link and using wireless-tools to manually configure the connection, this is what I had to do in arch on my mac.

As stated the wiki for backtrack is down and I can't find any help on the issue. I tried to do the full kernel upgrade suggested in my software update but after the update was complete and I logged back in I had a new log in manager and the only thing I was able to log into was window managers. However, after this update my wireless was working fine. Please help I am new to Linux and the wiki is down, I have nowhere else to turn.

Forgot to mention I am using the KDE version, not Gnome.

Thanks in advance for any help or support.

Attempt at make:

root@bt:/usr/src/compat-wireless-3.3-rc1-2# make
/usr/src/compat-wireless-3.3-rc1-2/config.mk:254: "WARNING: CONFIG_CFG80211_WEXT will be deactivated or not working because kernel was compiled with CONFIG_WIRELESS_EXT=n. Tools using wext interface like iwconfig will not work. To activate it build your kernel e.g. with CONFIG_LIBIPW=m."
make -C /lib/modules/2.6.38/build M=/usr/src/compat-wireless-3.3-rc1-2 modules
make: *** /lib/modules/2.6.38/build: No such file or directory.  Stop.
make: *** [modules] Error 2

lspci output:

root@bt:/usr/src/compat-wireless-3.3-rc1-2# lspci -vnn -i net

lspci: I/O error at net, line 0

root@bt:/usr/src/compat-wireless-3.3-rc1-2# lspci -vnn

02:00.0 Network controller [0280]: Atheros Communications Inc. Device [168c:0032] (rev ff) (prog-if ff)
        !!! Unknown header type 7f    ( This is the problem but I can't find the solution)
        Kernel modules: ath9k

iwconfig output:

root@bt:/usr/src/compat-wireless-3.3-rc1-2# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.
share|improve this question

1 Answer 1

http://www.facebook.com/cipher4u Hello, it wont detect unless BT is a host OS not an Guest. Better u go for a BT5 Live or take the latest Kali Linux Live. It will help you a lot. All the noobs in pentesting face the same probs. Solution as said, use BT Live or KL Live. Or Live USB will be great.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.