Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Realtek NIC in my Windows Home Server (essentially w2k3) box refuses to run at 1000Mb/s even if I change the driver settings from Auto Negotion to 1000Mb/s full duplex. I've installed the latest driver and tried changing the speed setting but I'm having no luck. Not sure what to try next. Any ideas?

EDIT: Good questions all I have a Netgear GS605 v2 Switch supports 10/100/1000 D Link DIR 655 Router All my machines bar one/2 have 1000Mb/s NICs (Old laptop/Xbox being the exceptions) The reason I noticed the problem was because I was copying files between two machines and maxing one NIC out and only seeing 10% on the other machine. I do have a fairly lengthy cable between the switch and the router (maybe 20m) could that be the issue?

Thanks Dave

share|improve this question
2  
Check if your Switch/Router/Hub supports 1000Mbps and that your cables are 5E certified. –  Michael B. Oct 20 '09 at 1:58

4 Answers 4

up vote 3 down vote accepted

As others have already noted you need to be connected to a gigabit switch and, of course, there will need to be other gigabit enabled computers connected to that switch to get any practical benefit.

Note that if you are using a garden variety router/modem/switch it is almost certainly going to only be 100Mbit.

The other thing to be wary of is the cables being used. Yesterday I tracked down a similar problem in my own network where one of the computers would only connect at a slow speed. It turned out to be a dodgy Ethernet cable. You will need cables marked as Cat5E or, preferably, Cat6.

share|improve this answer
1  
It was the cables! I finally found time to check all the cables between the two machines and switched out a couple of unarked cheapy cables for some Cat 5e ones and boom 1GBs. I'mamazed I was always very skeptical that cables made a difference. Thanks! –  David Hayes Jan 9 '10 at 16:04
    
I was skeptical when I read the solution but I tried it and replacing the cable also solved my problem and bumped speed on one of my computers from 100 to 1000 MBPS. Thanks! –  Guy Sep 11 '11 at 6:09

Where do you plug the ethernet cable into?
Is it a switch/router that only supports 100Mbit/s? If yes, then that's the problem.

share|improve this answer

If you are definately sure you're using a gigabit switch, you need to ensure that all the devices on the network (including the switch) are capable of auto negotiation. Otherwise, the devices will not show and operate correct speeds, and you'll have what's known as a Duplex Mismatch.

Other useful links on the topic:

share|improve this answer

Sorry to sound dumb here, are you sure you are using a gigabyte switch/router?

Need to rule this out, but I can't tell you the amount of jobs I have been on where this is the issue!

share|improve this answer
1  
Should say gigabit, not byte. –  MDMarra Oct 21 '09 at 23:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.