Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Corsair Flash Voyager GT with capacity of 16 GB bought roughly 5 years ago. It was working okay on all my computers, like a flash drive usually does. One day I lend it to my friend and when he brought it back, he told me he could not get it working. After that I could not get it working on any of my Windows systems too.

Symptoms:

  • The LED on flash drive doesn't blink;
  • The device is not present in Computer Management / Storage;
  • The device shows up under Other Devices / Unknown Device and Universal Serial Bus Controllers / Unknows Device in Device Manager;
  • Windows 7 also fails to find and install drivers for Unknown Device.

However, under Ubuntu 10.04 on my netbook, the flash drive is fully operational: I could easily back up data from it, format it (however formatting did not help to get it running on Windows). FYI the filesystem was NTFS, reformatted as FAT, so that's hardly the issue.

In addition, I tried to plug this flash drive into freshly installed Windows 7 x64 Ultimate. I read that it might be a driver problem. Unfortunately this was not of any help.

What can be cause of this? Given that the device is working okay in Ubuntu, I assume that the hardware itself is not damaged. And is there any way to fix it? If yes then how?

share|improve this question
    
Try GParted in Linux to delete all existing partitions on the drive (not just reformat) and then try it under Windows. Hopefully you'll get an option to initialize and format it, and then it should work. –  Karan Apr 1 '13 at 9:56
    
@Karan played around with GParted, unfortunately it did not help. Pendrive is still "USB device not recognized". –  Actine May 2 '13 at 12:50
    
Did you delete all partitions and then insert the completely unpartitioned/uninitialised/unformatted drive into the Windows PC? If the drive's still unpartitioned, try inserting it after running USB Oblivion on your Win PC (be sure to check the "Do real clean" checkbox). –  Karan May 2 '13 at 14:46

2 Answers 2

We all have friends who don't tell us everything that happened to the things we lend them. Have you tried reformatting the drive with a windows tool like the HP Key drive tool?

share|improve this answer
    
Your tool didn't install on my Windows 7 64bit environment. I tried HP USB Disk Storage Format Tool, but it didn't see my device. I will give it a try from Wine, but I doubt it will be helpful. –  Actine May 2 '13 at 13:02

4 GB and bigger pendrives should be formatted with FAT32. Try reformatting your pendrive to FAT32, maybe it will work.

share|improve this answer
    
I tried different filesystems, neither will work. The problem is probably with hardware, something not tolerated by Windows drivers, but tolerated by Linux. –  Actine May 2 '13 at 13:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.