Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I mostly connect to the Internet with a Reliance 3G dongle with these specifications:

enter image description here

This is how it looks in network adapters when connected.

enter image description here

The problem:

I want to virtualise this in Hyper-V but when I open the virtual switch manager to add a new switch, I don't see it in the list of adapters.

enter image description here

Due to this, I can't use the Internet in my VMs. Is there a way to do this without going to my ethernet broadband connection (which is slow)?

share|improve this question
    
Have you tried just sharing the USB device to the client and then connecting to the system as if it was directly plugged in? –  KronoS Apr 14 '13 at 3:44
    
Hyper-V doesn't let you share USB devices AFAIK –  pratnala Apr 14 '13 at 5:17

4 Answers 4

Hyper-V does not accept wireless adapters, and this "by design".

To force Hyper-V to accept a wireless network adapter, one must use the old trick of camouflaging it as a dummy but acceptable virtual adapter which is bridged to the dongle adapter.

Below is described how to bridge your dongle network adapter with a virtual network adapter on the host machine.

  • Open Hyper-V manager
  • Click on the Virtual Network Manager and create an Internal Virtual Network by selecting Internal and clicking Add.
  • Give a meaningful Name
  • Apply and OK
  • Now a Virtual Network has been created which can be associated with 1 or more virtual machines.
  • On the host machine, in the Network and Sharing Center click on Change Adapter Settings
  • Select your dongle adapter and the Internal Virtual Network you created.
  • Right click and select Bridge Network and the bridge is created.
  • In the Hyper-V Manager, right click the virtual machine and select settings
  • Add a Network Adapter and select the Internal Virtual Network you created initially from the drop-down list.
  • Click Apply and OK.

For more information here are some articles that look useful :

Hyper-V: How to Run Hyper-V on a Laptop
Using Hyper-V with a Wireless Network Adapter
Using Wireless with Hyper-V (using RRAS)

share|improve this answer
    
The icon in OP's screen cap shows the connection as a RAS connection which cannot be bridged. –  billc.cn Apr 7 '13 at 15:07
    
@billc.cn: You've got good eyes, but my last link show how to use it with RRAS. –  harrymc Apr 7 '13 at 15:44
    
I don't see a Bridge Network option –  pratnala Apr 8 '13 at 2:03
    
See this article for very detailed instructions : How to use Hyper-V with a wireless network connection. If nothing works for you, you could also try to Install the Microsoft Loopback Adapter in Windows 8 (must have IP segment address of 192.168.0.x). –  harrymc Apr 8 '13 at 6:10
    
But this isn't shown as a wireless network connection. –  pratnala Apr 11 '13 at 16:49

There is another way of doing this. Follow these steps:

  1. Open Hyper-V manager
  2. Click on the Virtual Network Manager and create an Internal Virtual Network by selecting Internal and clicking Add.
  3. Give a meaningful Name
  4. Apply and OK

Now go to your host machine and in the Network and Sharing Center click on Change Adapter Settings.

  • Select your dongle adapter and click Set as default connection.

  • Click properties and click on sharing tab.

  • Check Allow networks to share internet and select the internal connection just created.

  • Click Apply and click OK.

  • Finally go to your Virtual machine settings and select the internal switch we created and click Apply and OK.
share|improve this answer

You'll have to use internet connection sharing or similar to share the dongle's connection with your VM's virtual network card. There's no way to bridge a RAS (dial-up) connection.

An alternative is to share the USB dongle with the guest OS and initialize the connection from the guest. You'll have to use remote desktop to achieve this as Hyper-v does not natively support USB pass-through.

In general, Virtualbox is a better choice for this kind of applications.

share|improve this answer
    
I just got myself VMware. It is miles and miles better. Hyper-V is only there for WP8 emulator. –  pratnala Apr 7 '13 at 15:43
    
I believe Virtualbox does not support wireless dongles. –  harrymc Apr 7 '13 at 16:17
    
It supports USB pass-through which is the easier solution here. –  billc.cn Apr 7 '13 at 18:30

I am using a Clear Wi-Max device by directly connecting the device to the guest OS and letting the guest OS setup the connection within it's purview.

This may not be what you are looking for what it's worth a shot. If you planning to share the connection between the guest and the host that's another problem. If you want to share bridge it with one of the virtual Ethernet cards.

share|improve this answer
    
How can you connect the device directly to the guest OS? Hyper-V doesn't have the feature to pass USB devices –  pratnala Apr 13 '13 at 9:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.