Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

All been great with my Cyrillic character output in osd_cat until I created ~/.fonts.conf (at least this is the most obvious reason I'd think) with such settings (as seen on debian forum):

<?xml version="1.0"?><!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<match target="font">
<edit mode="assign" name="rgba">
<const>rgb</const>
</edit>
</match>
<match target="font">
<edit mode="assign" name="hinting">
<bool>true</bool>
</edit>
</match>
<match target="font">
<edit mode="assign" name="hintstyle">
<const>hintmedium</const>
</edit>
</match>
<match target="font">
<edit mode="assign" name="antialias">
<bool>true</bool>
</edit>
</match>
<match target="font">
<edit mode="assign" name="lcdfilter">
<const>lcddefault</const>
</edit>
</match>
</fontconfig>

After that (and system reboot, of course) fonts look "better", but any Cyrillic word is shown as .. Here are my osd_cat script settings:

/usr/bin/osd_cat -f -*-*-*-*-*-*-20-*-*-*-*-*-koi8-r --delay=4 -c green -s 1 -A center -p top -o 45 --age=4;

I already tried specifying some server-side monospaced fonts (koi8-r), found through xlsfonts -fn '*-*-*-*-*-*-*-*-*-*-*-c*' command, e.g.

/usr/bin/osd_cat -f -misc-fixed-medium-r-normal--0-0-100-100-c-0-koi8-r --delay=4 -c green -s 1 -A center -p top -o 45 --age=4;

but nothing seems to be changing.

Please, help me out.

share|improve this question
up vote 0 down vote accepted

Turns out it was a locale problem. Was fixed by adding

export LC_ALL="ru_RU.koi8-r"

line in my initial script.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .