Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday my PC gave me somewhat of a heart attack when it prompted a BSOD while I was fiddling around with a midi device selection. Anyway, when I rebooted the system, startup repair showed up and cheerfully reported the problems could not be solved automatically. Another restart - startup repair yet again. No matter what option I select (Start Windows normally/startup repair), I always end up with startup repair. I tried to follow this post but DIR on C: results in "File not found". So I ran CHKDSK C: which does not find any errors but also only lists around 100MB of my 80GB SSD.

Any advice on how to proceed from here would be very much appreciated.

Update

I found that somehow the drive letter of my SSD was changed from C: to F:. When I run CHKDSK F: I get the expected result (no errors, correct drive size) and I was able to follow the instructions from the post I mentioned earlier. However my system is still booting into startup repair.

share|improve this question
3  
First thing first, make a byte-level copy or image of that SSD to someplace else before taking any further action. Pretty much anything you do at this point is likely to include some pretty low-level work (it sounds at a glance as though the root directory or possibly the MFT might be corrupted) so the ability to restore to a known (albeit broken) starting point may prove invaluable. –  Michael Kjörling Apr 1 '13 at 11:10
    
That said, do you have a recent backup? Because frankly, the easiest way to restore from this might very well be to reformat the drive and restore a recent backup. –  Michael Kjörling Apr 1 '13 at 11:12
    
If you don't have a complete backup of your user files, then now is the best time for you to explore your options concerning using a Linux live CD to backup your files. Do this before it's too late. Also some Linux live CDs are easier to use than others, so I recommend choosing a live CD that is easy to use. –  karel Apr 1 '13 at 11:33
    
It might help to use an external Knoppix or BartPE CD/DVD boot to repair the filesystem on the SSD. If CHKDSK just recognizes 100MB of 80GB, the filesystem is most likely corrupted. Once you have the filesystem back, you can restore the last healthy safepoint. –  Axel Kemper Apr 1 '13 at 11:35
    
Basically there's only the OS on that drive. I tried to access the drive via a Live USB Installation. Ubuntu apparently couldn't handle the GeForce 580 and froze. Tried Knoppix which didn't recognize neither mouse nor keyboard. I finally decided to format the drive and reinstall windows. This is when I found out that my former SSD drive with the OS (C:) on it, is now to be found under the drive letter F:. What's going on here? DIR seems to work now. –  hauptbenutzer Apr 1 '13 at 12:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.