Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am batch converting a lot of files and running vlc from the command line. When I do a new dos box pops up showing vlc's output converting the current file. It is very annoying because it pops up above all other windows and takes focus.

How do I hide VLC either completely or minimized.

share|improve this question

No need for Command User Interface (DOS) commands. The switch is within the app. Click on TOOLS MENU > PREFERENCES (or Ctrl+P). Under INTERFACE... Turn this off: "Systray pop-up when minimized" CHECKBOX. Systray will still notify you with a little balloon. But the video itself will no longer pop up.

share|improve this answer

Either minimise or run VLC using the command line with the --qt-start-minimized option. (ex:vlc.exe sourceUrlStreamOrFile.mp3 :sout=#file{dst="D:\\targetFile.mp3"} :sout-keep --run-time=65 --stop-time=65--qt-start-minimizedvlc://quit)

Then while running, turn off "tools/preference/interface/Systray pop-up" option to prevent any popup from the system tray icon.

Then to run your batch, use cmd /c start /b yourbatch.bat

share|improve this answer

Try putting >nul on the end of the vlc command.

share|improve this answer

Adding --quiet and --dummy-quiet -I dummy suppresses the popup window.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .