Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When installing Notepad++ on Windows 7 64-bit, I receive this error:

Error opening file for writing:

C:\Program Files (x86)\Notepad++\langs.model.xml

Click Abort to stop the installation,
Retry to try again, or
Ignore to skip this file.

Of course, if I click Ignore, it will just error out on the next file and the next file (if I click ignore, yet again), and so on.

After searching Google, I found a lot of people who received a similar error when trying to load it (after the install), but no one who experienced this problem on an install. Is there a workaround to this?

share|improve this question
    
Does the file langs.model.xml already exist? From a previous installation? It might help to repeat the installation as Administrator and/or to remove the old installation beforehand. –  Axel Kemper Apr 1 '13 at 15:09
    
It does not exist, nor does any previous installation exist. I tried installing as the Admin, yet it still generates this error. Even if I ignore this error, it will just error out on the next file. –  Question3CPO Apr 1 '13 at 15:14
    
There is a spelling error in Notepadd++. It should be Notepad++ with a single d. –  Axel Kemper Apr 1 '13 at 15:16
    
Thanks @AxelKemper; unfortunately, that was my own error. –  Question3CPO Apr 1 '13 at 15:18
1  
Try to install Minimalist instead of custom installation.. –  user305139 Mar 5 at 5:11

8 Answers 8

up vote 7 down vote accepted

Download the ZIP package from the Notepad++ website. Unzip it, and then copy the langs.model.xml file from the package into C:\Program Files (x86)\Notepad++.

The application doesn't necessarily need to be installed, either. You can always just unzip the package to your preferred location and then launch the application directly from that folder. Should work just as well.

In any case, I believe you answer lies in downloading the .ZIP version of Notepad++, not the Windows Installer.

share|improve this answer
    
Thanks @dtdlurch; awesome hack - worked perfectly! (I would upvote it, but lack the rep - nonetheless, thanks). –  Question3CPO Apr 1 '13 at 15:28

I encountered the same problem when tried to install the latest version, npp.6.3.2.Installer.exe.

One solution is: right click and Run as Administrator. It works properly then.

share|improve this answer
    
This should be the accepted answer as it addresses the main problem. The windows installer is just fine and needs no hacks. –  tryurbest Jul 7 at 21:13

I just experienced the same issue with the new v6.3.2. Uninstalling, rebooting, and trying the previous version resulted in the same failure.

I ended up starting an "Administrator" command prompt and running the installer from there. It worked.
> pushd %USERPROFILE%\Downloads
> npp.6.3.2.Installer.exe

I think the Windows installer is failing to launch the UAC prompt to request admin rights when double-clicked. The command prompt trick works around this.

share|improve this answer

We ran into this at the office. UAC was enabled. The setup program doesn't elevate itself. Right-click on the installer and, "Run As Administrator."

share|improve this answer

I had the same error, it was a permission issue. I opened the entire folder (.\Notepad++) up to EVERYONE full access as well as edited the special permissions in Advanced settings and chose to

"Replace all child object permission entries with inheritable permission entries from this object"

for the installation and it worked.

share|improve this answer

It looks like the NPP installer requires admin rights. To grant the permission:

  1. Right Click the installer npp.x.x.Installer.exe and
  2. Chose to Run as Administrator
  3. The installer will get the authorization it needs and complete in seconds.
share|improve this answer

On a PC with UAC enabled, the oft-mentioned answer of "Run the installer as Administrator" is not descriptive enough, because if you install it in the default location Programs (x86) then every time you use the program as a non-Administrator you will get the annoying UAC pop-up "This program wants to make changes to your computer..." very annoying. The other answer "don't install it, just unzip it in My Documents and run it" is also insufficient because then I found that you cannot set Notepad++ as the default application for specific file types (maybe because it was not officially installed?) --- So my solution that takes care of both issues was to run the installer as Administrator, but override the install location to my own personal My Documents\Programs\Notepad++ folder. Now both issues are solved.

share|improve this answer

I encountered the same problem on Windows 7 64 Bit, when installing Notepad++ version 6.5.5.

Running the installer as Administrator solved the error in the installation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.