Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to run the Cruise Control.net web dashboard on a Windows Server 2003 machine with IIS6 and I am running into the following error when I go to the default landing page for the dashboard:

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The format of the file 'ThoughtWorks.CruiseControl.WebDashboard' is invalid.

Source Error:

Line 8: Line 9: Line 10: Line 11: Line 12:

Source File: C:\CruiseControl\Application\webdashboard\web.config
Line: 10

Assembly Load Trace: The following information can be helpful to determine why the assembly 'ThoughtWorks.CruiseControl.WebDashboard' could not be loaded.

=== Pre-bind state information === LOG: DisplayName = ThoughtWorks.CruiseControl.WebDashboard (Partial) LOG: Appbase = file:///C:/CruiseControl/Application/webdashboard LOG: Initial

PrivatePath = bin Calling assembly : (Unknown).

LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind). LOG: Post-policy reference: ThoughtWorks.CruiseControl.WebDashboard LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/cruisecontrol/c8c373af/413fb329/ThoughtWorks.CruiseControl.WebDashboard.DLL. LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/cruisecontrol/c8c373af/413fb329/ThoughtWorks.CruiseControl.WebDashboard/ThoughtWorks.CruiseControl.WebDashboard.DLL. LOG: Attempting download of new URL file:///C:/CruiseControl/Application/webdashboard/bin/ThoughtWorks.CruiseControl.WebDashboard.DLL.

As you can see, the error says the issue is line 8, 9, 10, 11, 12 from web.config - which looks like this:

<system.web>
<httpHandlers>
<add verb="*" path="*.aspx" type="ThoughtWorks.CruiseControl.WebDashboard.MVC.ASPNET.HttpHandler,ThoughtWorks.CruiseControl.WebDashboard"/>
<add verb="*" path="*.xml" type="ThoughtWorks.CruiseControl.WebDashboard.MVC.ASPNET.HttpHandler,ThoughtWorks.CruiseControl.WebDashboard"/>
</httpHandlers> 

So, this same exact config works without any modification in IIS7 or IIS7.5 on Windows 7 or Windows Server 2008. I am guessing the root cause is some declaration that is not understood by IIS6 - but I am not sure.

Anyone know how I can re-structure my web.config file so I can run Cruise Control.NET in IIS6?

I should also mention that I have not added any ISAPI filters or anything to my IIS6 config. I am not sure if I need to register the dll's with IIS6 or not.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Looks like it's attempting to use .Net 1.1, whereas newer versions of CruiseControl require .Net 2.0 (see here: "Required is a least .NET 2.0 or Mono 2.10").

You also may want to ensure you've registered .Net 2 with IIS. You can do this by running the aspnet_regiis.exe found in \Windows\Microsoft.NET\Framework\v2.0.50727\.

Here's some more info discussing installing CruiseControl.net in IIS6:

Configuring CruiseControl.NET for IIS 6.0

In your system's IIS Admin tool:

  1. Map a virtual directory to the 'webdashboard' subfolder of your CCNet folder (typically called ccnet)
  2. In the configuration for this virtual directory, click the Configuration button of the Virtual Directory tab
  3. Click Add to add a new Application Mapping
  4. In Executable, enter the location of the aspnet_isapi.dll file you use (look at the .aspx mapping as an example. A typical value would be c:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_isapi.dll for CruiseControl.NET release 1.2.1 or earlier, or c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll for later releases)
  5. In Extension, enter .xml
  6. Make sure Script engine is checked and Check that file exists is not checked
  7. Click OK as necessary to save your changes
  8. Under the Virtual Directory's Documents tab make sure that default.aspx is added as a default document

Incase of "Page cannot be found" error

The security settings in Windows 2003, prohibits ASP.NET ISAPI. Here is how you should solve this:

  1. Click on "Web Service Extensions" in IIS
  2. Select "All unknown ISAPI extensions"
  3. Click on "Allow"
  4. Select "ASP.NET vx.x"
  5. Click on "Allow"
share|improve this answer
    
Perfect - thanks for looking that up for me :) –  Richie086 Apr 1 '13 at 18:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.