Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My keyboard had been working properly for 4 months, but all of the sudden, the settings for Delay and Speed in System Tool → System Settings → Keyboard → Typing → Repeat Keys got ignored.

I have restarted the machine, but it didn't help.

To troubleshoot, I've even set the delay to zero, but there is still about a 1.5 second pause. Then I set it to the maximum value; there's still the same 1.5 second pause.

In addition I have attempted to rectify this from the command line

$ sudo kbdrate -d 250 -r 22
[sudo] password for user1: 
Typematic Rate set to 21.8 cps (delay = 250 ms)

Once again, the delay and rate remain unchanged after running this command.

I am using Ubuntu 12.04 with GNOME Classic.

share|improve this question
    
What setting exactly? CCSM is the compiz settings manager. What have you set up? What have you changed? Are you sure you are using compiz? – terdon Apr 1 '13 at 17:14
    
I corrected the question. – javadba Apr 1 '13 at 18:01
    
Thanks for the edit, now what is this delay you have set to 0? There is a pause when doing what? What settings are being ignored? – terdon Apr 1 '13 at 18:03
    
Typing | Repeat keys. – javadba Apr 1 '13 at 18:05
    
I just found a related post ubuntuforums.org/archive/index.php/t-978590.html – javadba Apr 1 '13 at 18:30
up vote 2 down vote accepted

I finally found a way to change the keyboard settings:

xset r rate 250 30

Executing xset shows:

To turn auto-repeat off or on:
    -r [keycode]        r off
     r [keycode]        r on
     r rate [delay [rate]]

This command worked. kbdrate and the System Settings GUI tools did not.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .