Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I find myself turning on wireless in the mobility screen (like this) almost every day. The power settings screen shows maximum performance for wireless.

Any ideas? Thanks

EDIT:

  1. In the adapter properties/power management it is not configured to be turned off to save power.

  2. I remembered that it mostly happens AFTER sleep mode, like if it sleeps for a long time and I wake it up - it's almost guaranteed I'd need to turn "wireless" on

share|improve this question
    
Please run command prompt as Administrator, enter powercfg -energy and post the result file. For more info see Use PowerCfg in Windows 7 to Evaluate Power Efficiency. –  harrymc Apr 26 '13 at 5:55
    
@harrymc - pastebin.com/JUB3MYZd (raw html) or pastebin.com/d6eV3DY1 (text paste) –  Madd0g Apr 27 '13 at 2:20

3 Answers 3

up vote 0 down vote accepted

Did you check your bios setting yet ? some laptop can set to turn off wireless on sleep in the Bios.

or you can make the following a bat file:
netsh interface set interface "Wireless Network Connection" Enable

then put that in window scheduler, run on workstation unlock. then the wifi would turn on everytime you unlock your laptop screensaver.

share|improve this answer
    
yep, looked at all BIOS screens, couldn't find anything related to power or wireless –  Madd0g May 6 '13 at 16:12
    
the scheduler idea is a good one, I'll try to see if I can do it on wakeup instead of on login (I often want to remote control into the computer, so login is a bit too late). this suggests it's possible –  Madd0g May 6 '13 at 16:13
    
so, does it works ? –  Antony Lee May 16 '13 at 12:51
    
automation saves lives ;) –  Madd0g May 16 '13 at 18:54

In the powercfg -energy report I find two suspicious entries :

USB Suspend:USB Device not Entering Suspend

Power Policy:802.11 Radio Power Policy is Maximum Performance (Plugged In)
The current power policy for 802.11-compatible wireless network adapters is not configured to use low-power modes.

You might consider disconnecting all unneeded USB devices after reviewing their power options, as well as setting the wireless on battery to some power-saving mode, but I don't believe that this alone will fix the problem.

I don't know if the above warnings are connected to the problem, but my advice is:

  1. Update all drivers and firmware (including BIOS) from the G74Sx download page.
  2. Run Windows Update, Search for updates, and patch everything including optional updates. Reboot and repeat until no more updates are found.
  3. If the problem remains, run Microsoft's USB troubleshooter from Internet Explorer
  4. If nothing works, do Repair Install to fix Windows and preserve user accounts, data, programs, and system drivers.
  5. I advice against the obvious next step - reinstalling Windows. In the worse case, one can create a batch script for turning on the wireless so as to make it easier on you.
share|improve this answer
    
great answer, yes, bios is probably a little outdated but most of the other stuff should be pretty recent, I'll try to update anyway. I'm wondering about what you said about USB, all I have connected is the mouse and I don't see how it can be related to the wireless adapter –  Madd0g Apr 27 '13 at 11:09
    
I don't think it's the mouse not sleeping, but rather the usb hub controller. This is probably normal if the usb mouse needs to wake-up the computer. –  harrymc Apr 27 '13 at 13:45
    
Question: Is the wireless marked as allowed to wake up the computer? –  harrymc Apr 29 '13 at 7:29
    
where is that setting again? do you mean the wake-on-lan? is it only in the bios or is there a windows setting? –  Madd0g Apr 29 '13 at 21:47
    
Yes, I meant setting both Wake on Lan options in Device Manager / Network adapter / Properties / Power Management. Sometimes it is also in the BIOS at the Power management section or maybe called "Power On By PCI Devices" or somewhere else depending on the version. –  harrymc Apr 30 '13 at 5:49

copy this link into your windows explorer "Control Panel\Network and Internet\Network Connections"

Right click your wireless card. Go to Properties. Click the configure button choose power management tab. Uncheck "allow the computer to turn off this device to save power."

share|improve this answer
    
it was unchecked: image –  Madd0g Apr 2 '13 at 11:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.