Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a laptop whenever trying to use wireless or wired internet in the task bar it says "limited connectivity" and the internet cannot be accessed. If I right click on the icon and select "trouble shoot" it scans for errors and finds "DHCP is not enable, click fix to try to fix these problems as administrator". Then the internet is accessible. How can I fix the problem so I can use the internet right when I turn on the computer?

screen shot after repairs applied

I'm running Windows 7 on an HP laptop with a built in wireless adapter.

share|improve this question
    
I have the SAME problem with Win7 and 8, so I'm excited to see some of the answers. –  MarcusJ Apr 2 '13 at 3:01
    
connect wirelessly, and open a cmd prompt and type "ipconfig /all" and paste the results in your post. THen connected with the wired and do the same... posting the results here. –  Logman Apr 2 '13 at 3:04
    
quick fix maybe, try turning off and unplugging the router/modem. Disconnect your computer from the router/switch/modem too. WAit a 30 seconds or more. Then plug everything back on, then turn ON the modem, then router, then switch and computer –  Logman Apr 2 '13 at 3:08
    
@MarcusJ if you feel like it up vote the question so it gets more attention –  Celeritas Apr 2 '13 at 4:11
    
@Logman I will post "ipconfig /all" asap. By the way, I've tried connecting to totally different networks and the problem is still the same so I don't think it's a problem with the router. –  Celeritas Apr 2 '13 at 4:12

1 Answer 1

Go to Start, Control Panel, Network and Sharing Center, and on the left side, click on Change Adapter settings, click on the network adapter that you want to connect to, and in the window that pops up, click on the Properties button. In the next window, select Internet Protocol Version 4 (IPv4). Click on the Properties button. Make sure the Obtain IP Address automatically and Obtain DNS Server Address radio buttons are selected, then click Ok, and close the rest of the windows. It should then connect to the network on boot.

share|improve this answer
    
I do find it interesting, though, that DHCP is not enabled by default. –  Davidw Apr 2 '13 at 3:42
    
It is. Someone changed these settings and now they are default. –  ϺОŞΣŞ Apr 2 '13 at 4:03
    
Did my answer resolve the issue? –  Davidw Apr 2 '13 at 4:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.