Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 8 Pro, and I've enabled Hyper-V in order to run a few Windows virtual machines on my workstation. For the guest VMs, I'd like them to be able to have access to network resources outside of the host network, including the internet.

Here's what I've tried so far:

  1. I've set up an Internal network in the Hyper-V Switch Manager, and shared the NIC that has internet access with the new virtual switch via Internet Connection Sharing

  2. Then, I created a VM and assigned the Internal virtual switch to that VM's network adapter. The VM then gets an IP address in the 192.168.137.x range, with the gateway, DHCP server and DNS server set to 192.168.137.1.

The Windows Server 2012 VM says it's not connected to the internet, and I'm not able to open any webpages on the guest. The host OS has internet access via Ethernet during this time (not trying to use a Wi-Fi connection with this setup), and the switch is configured to allow the guest and host OS to use it simultaneously.

I've followed closely to the steps lined out in three related questions, but I don't see anything I should change:

Any suggestions on what I should try or change next?

share|improve this question
    
I assume you have installed the VM Additions ( i.e. the drivers ) right? –  Ramhound Apr 2 '13 at 11:47
    
The guest OS' I've tried are Windows Server 2012 and Windows 8 without success. Although they came with the drivers I believe, I also upgraded them and didn't see any change after a reboot. –  Cory Plastek Apr 2 '13 at 12:57

1 Answer 1

up vote 1 down vote accepted

It's working, although I'm not exactly sure which of the below steps actually fixed my issue:

  1. Before creating an internal network, I had created an external network. I deleted this network and re-created the internal network.
  2. Disabled and re-enabled both the physical NIC and virtual NIC.
  3. Removed and then re-enabled Internet Connection Sharing.

I was trying quite a few things to get this to work, and somehow I've stumbled upon it now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.