Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Ubuntu 12.04 with Windows 7 - and upgraded to Ubuntu 12.10 recently - Ubuntu installed the GRUB (version 2.00-7ubuntu11) boot menu. When I first got Ubuntu, I changed the default OS to Windows 7. But now I have added a splash screen/background it has been misaligned, offset from the right and bottom sides of the screen. In the GRUB config file I have:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="Windows 7 (loader) (on /dev/sda3)"
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

# User added background
GRUB_BACKGROUND=/home/comp500/Pictures/grubsplashv2.png

GRUB_GFXMODE=1366x768

How would I realign it to my screen size? (1366x768, Dell S1909WN Monitor, only one monitor) The Splash Screen is a .png file made in gimp at 1366x768 resolution but that is offset with the menu. (Aligned correctly to the menu) I did vbeinfo and found 1366x768 is not supported in GRUB_GFXMODE but when I set it to 1024x768 nothing changes. (I have done update-grub) Update: I checked my monitor's menu screen, and it says GRUB is running at 1024x768, and when I use the auto-align function it partly aligns it. Is there any way to make GRUB display at 1366x768, or display at 1024x768 in the middle of my 1366x768 screen? When Ubuntu and Windows launch it is at full resolution and aligned correctly as usual.

share|improve this question

1 Answer 1

I know it's not very helpful (at least, not to me!), but I found that commenting the GRUB_GFXMODE option aligns the background image correctly. The reason this didn't help me much is that it

  1. caused loss of resolution to the background image
  2. changed the resolution and alignment of all other elements
  3. (worst of all) caused strange color issues with image elements where they grew darker while scrolling through the boot menu

This isn't the solution, but perhaps it's a step in the right direction?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.