Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem starting the Apache Service in WAMP Server, when i test port 80, I get the following message on the console

Your port 80 is actually used by :
Server: Microsoft -HTTPAPI/2.0

Things i did:

used netstat -aon from the command prompt to check what is running on port 80 and i get something with a PID of 4.

This PID of 4 corresponds to a file named - ntoskrnl (NT Kernel & System) in C:\Windows\System32

How do I go about solving this issue?

share|improve this question

migrated from stackoverflow.com Apr 2 '13 at 10:07

This question came from our site for professional and enthusiast programmers.

2  
A common error is running Skype. It too uses port 80 and won't let wamp start up. –  Ancientar Apr 2 '13 at 10:02
    
I had already unchecked that option in Skype before, but no luck! –  Neville Apr 2 '13 at 10:25
add comment

4 Answers

up vote 2 down vote accepted

I finally found out the culprit, it was the SQL Server 2012 reporting and analysis services that were using port 80.

I opened up services.msc from the command prompt, disabled both these services and WAMP Server works perfectly now with no localhost problem.

Thanks to all those who provided the answers to this question, they were right but unfortunately all the solutions presented had already been applied in my case.

share|improve this answer
    
Select this as the correct answer to show it as answered. It is the correct way of doing it here even if you don't get any rep yourself. –  MoonSire Jul 6 '13 at 20:06
    
Hey, thanks for reminding this , i was totally unaware of it. Thank You... :) –  Neville Jul 9 '13 at 3:21
add comment

try this

 Browse to your httpd.conf under the Apache menu and find the line "Listen 80"

  Just change it to something like "Listen 8088" and restart Wampserver.

  If everything is fine, your little Wamp Icon on the systray should be white and  
   everything should be good to go.
share|improve this answer
1  
This feels like: instead of fixing it just sweep it under the carpet. –  PeeHaa Apr 2 '13 at 10:10
    
Is there any way to fix it rather than changing or making it listen to a different port? –  Neville Apr 2 '13 at 10:21
add comment

From what it looks like, your system is already running IIS server which is using port 80.

You can disable it by going to Control Panel -> Uninstall Programs -> Turn Windows Features On or Off -> uncheck Internet Information Services

You should then try restarting your Wamp server (and your computer as well, if needed).

It might also be worth checking the entries in your HOSTS file located at

WINDOWS\System32\drivers\etc

There should be just one entry for your localhost i.e:

127.0.0.1 localhost

share|improve this answer
    
Hi, IIS is unchecked by default, even the host file has only 1 entry as you specified. Any other solution? –  Neville Apr 2 '13 at 13:43
    
This is quite a bit of research and should help you : graftalks.blogspot.in/2012/11/… –  Anurag Apr 2 '13 at 13:48
    
And here is one more solution that might work for you: yetmorestuff.net/index.php/2011/08/18/… Sorry I cannot test these, as I am not in Windows 8 currently. –  Anurag Apr 2 '13 at 13:50
add comment

In my case it was Skype. This is how to find out:

Use netstat- aon to see what PID is using port 80.

Use tasklist to see what process hides behind that PID.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.