Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 13" Sony Vaio laptop (model SVS13A1C5E) and I upgraded it to Windows 8 with a fresh install, after upgrading I installed Win8 drivers listed here.

Now I have a problem with the CPU usage (it drains my battery), in Task Manager I can see that the "system" process is always using 15-20% of my CPU (i7-3520M) and looks like the usage is on a single core. This is what I found by using Process Explorer, the usage comes from ACPI.sys which looks like it is generating a lot of hardware interrupts.

Process Explorer- Screenshot

By doing some research I found out that should be an issue with some drivers but I don't know how to figure out which one is causing this. (Please do not tell me to "upgrade" to Windows 7)

share|improve this question
2  
have you installed intel chipset drivers? ACPI.sys is the driver for the Automatic Configuration Power Interface, which handles a lot of low level details with device power. if its experiencing interupts, then it is likely that the driver is using your hardware incorrectly. –  Frank Thomas Apr 2 '13 at 19:35
    
Yes, I installed Intel chipset drivers but you just reminded me that I had a strange behavior when installing "Intel ME Drivers": when installing other drivers there's always been some window popping out with some instructions (or a windows prompt) but when installing ME drivers the computer looked like it was working on something but nothing shown and so I do not know if they installed correctly or not. Could this problem be related also to ME drivers? –  Dan Apr 2 '13 at 19:42
    
interesting. yes, Intel ME is low enougn to cause an issue. do you even really need to remotely manage your bios? If not, remove it. –  Frank Thomas Apr 2 '13 at 19:45
    
do you mean removing drivers? I uninstalled it from Device Manager and after rebooting the device automatically installs again with (I think) drivers included in Win8 and the problem persists. –  Dan Apr 2 '13 at 20:03
    
ahh. you could disable the device, but it may not be worth it. Diogo's response while not immediately effective has the ring of truth to it. –  Frank Thomas Apr 2 '13 at 20:10

2 Answers 2

up vote 2 down vote accepted

I fixed it! The problem was the BIOS, I updated it after installing Windows 8 (it was a win8 specific update) but it looks like it contained some bugs. If someone have this problem and needs to revert the update here you can find some bios mods based on the original version but also the stock one: http://forum.notebookreview.com/sony/677079-sony-vaio-s-bios-mod-gt640m-le.html

Also: With the updated bios version I was not able to see my Bluetooth, now it's working. Thanks all for the help given.

share|improve this answer
1  
Had this same issue on a Dell Latitude E6430, Win 7 64 bit. In this case I used LatencyMon. It was a combination of about 10% of total CPU being used by intel ethernet power savings stuff so disabled all that. Then the remaining 10% usage I got rid of by updating the BIOS. I think it was 3 revisions behind A11 vs A14 which had some explicit ACPI stuff mentioned in the release notes. –  ThePosey Mar 7 at 14:56

I had similar issue with Dell E6540, 8 cores, one core permanently at 100%, process: System, thread: acpi.sys. Thanks to @ThePosey I tried to turn off Device Manager -> Network Adapters -> Intel(R) Ethernet Connection I217-LM. Process usage immediately dropped to 1%. When turned on -> one thread started to work at 100% again. Then I noticed that when I switched Power Options -> Power Plans, CPU usage characteristic changed (one core 100% -> 80%, other core 0% -> 50%, depended on the selected profile). Then I researched the problem further and found out a solution: Network Connections -> Intel(R) Ethernet Connection I217-LM -> right click Properties -> Configure -> Power Management -> section Wake on LAN -> disable Wake on Magic Packet AND Wake on Pattern Match. Process usage immediately dropped to 1%, problem solved.

share|improve this answer
    
That's it! You made my day!! –  jdehaan Dec 9 at 10:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.