Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just recently uninstalled Office 2010 32-bit and installed Office 2013 64-bit on my computer. I was sent some text files that are tab-delimited, so I want to open them with Excel.

I am trying to add Excel to the Open With... option in the right-click menu in Windows 7. Every time I try, I open the selection screen, browse to Excel.exe in the Office15 folder and press OK, but it refuses to stay as an option on the selection screen.

I know that I can open Excel and then open the file, or even drag-and-drop it onto Excel, but seeing as I'll be opening a lot of these files over the next few weeks, I'd really rather add it to the right-click menu (like I used to do all the time).

Any ideas as to why it won't allow me to open that way or how to fix it?

share|improve this question
    
do you want to open that type of file with excel all the time? –  Dilshod Apr 3 '13 at 0:52
    
Not really, because they are all .TXT which I normally open with Notepad++. However, I have tried that and it won't allow me to even make it the default program. Excel simply won't be allowed in the Open With window at all, for some reason. –  techturtle Apr 3 '13 at 0:54
    
so it worked before and stop working after installing Office 2013? –  Dilshod Apr 3 '13 at 0:58
    
Can't say 100% that it used to work on this machine, but I know that I have the same basic setup at work (Win7x64, similar other installs) but still with Office 2010 and it does work there. –  techturtle Apr 3 '13 at 1:02
    
how did it go ? –  Dilshod Apr 3 '13 at 1:18

5 Answers 5

Press Win+R and type regedit. Then open this:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.txt\OpenWithList

and add new value in that place. there must be a, b, ... so you name your value c if you have a,b. Put this text "EXCEL.EXE" without quotes into a value data and see if this work.

Bee careful with registry things!

share|improve this answer
    
I figured there would be a place like this in the registry, but didn't know where to find it. Unfortunately, this won't work because I already had EXCEL.EXE in there (at position C) and it's still not in my right-click menu. –  techturtle Apr 3 '13 at 1:20
    
ok then try deleting it from there and add it again(do not add from registry). –  Dilshod Apr 3 '13 at 1:22
    
Got it working eventually. +1 because your solution should work for most people and for sticking with me trying to fix this. Thanks! –  techturtle Apr 3 '13 at 2:11
up vote 0 down vote accepted

Finally figured it out. It was directly related to the switch from 32-bit to 64-bit. Poking around the registry I found the following key was wrong:

HKEY_CLASSES_ROOT\Applications\EXCEL.EXE\shell\open\command\(Default)

Within this key was the following "old" value:

"C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE" "%1"

When I changed it to the correct, new location for Excel, it started working immediately.

"C:\Program Files\Microsoft Office\Office15\EXCEL.EXE" "%1"
share|improve this answer

you're right on the mark, but mileage may differ..

That is, the correct registry value in my case is:

"C:\Program Files\Microsoft Office 15\root\office15\EXCEL.EXE" "%1"

And yes, it started working right away. Awesome!

share|improve this answer
    
Please don't post comments as answers. Your contribution is not an answer. If you want to post a comment, earn the 50 rep required. Until then, just hold that thought. –  teylyn May 11 '13 at 9:14

It works for me but in different way. I have changed it from

"C:\Program Files\Microsoft Office\office14\EXCEL.EXE" "%1"

to

"C:\Program Files\Microsoft Office\office15\EXCEL.EXE" "%1"
share|improve this answer

I had a similar problem except mine was with PowerPoint 2013.

A work computer had Office 2007 installed on it and needed to keep Outlook 2007 on the computer, so I did not uninstall Word, Excel or PowerPoint 2007. I then installed Office 2013 thinking it would default to the newest version. However this was not the case and no matter how many times I choose to "open with" PowerPoint 2013 and set it to the default open program, it would always open in 2007.

The trick was as techturtle described above except there was no POWERPNT.EXE key in the registry.

I had to go to:

HKEY_CLASSES_ROOT\Applications\

then:

  • right click on the folder and choose insert key "POWERPNT.EXE"
  • again insert key "shell"
  • insert key "command"
  • insert key "open"

so I created my own registry key for POWERPNT.EXE that looked like this

HKEY_CLASSES_ROOT\Applications\POWERPNT.EXE\shell\open\command\(Default)

Once that was done I placed the location of the PowerPoint 2013 executable in the (Default) key. Which for me was:

"C:\Program Files\Microsoft Office 15\root\office15\POWERPNT.EXE" "%1"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.