Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have posted the question "Kubuntu 12.10 laptop battery dropping fast" and there i have received the answer as

accept As advised on another Stack Exchange forum, the procedure to accomplish an answer to your question would be:

adding the following kernel parameters

i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 pcie_aspm=force plus:

Adding to /etc/default/grub, Line starting with GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm i915.i915_enable_rc6=1 i915.lvds_downclock=1"

(remember to sudo update-grub after editing)

I am new to Unix OS and i don't have knowledge on how to achieve above steps.

It would be really helpful, if some one provides me steps on above.

share|improve this question
  • You need to edit the file /etc/default/grub (using sudo nano /etc/default/grub or some other editor) and look for the line that looks something like:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

(you may have different options in it)

Change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm i915.i915_enable_rc6=1 i915.lvds_downclock=1"

i.e. add pcie_aspm i915.i915_enable_rc6=1 i915.lvds_downclock=1 into the options

  • Save the file and run:

    sudo update-grub

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .