Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I get the "Customizable Hot Keys"(2) to work?

Microsoft Natural Ergonomic Keyboard; Hotkeys labelled with 2

The threads that I found did not result in anything useful. Some sites suggest recompiling the kernel, which does not sound like something I'd like to do. Did anyone get them to work?

I'm using the Ubuntu 9.10 Beta.

share|improve this question
    
    
I already found that and since it says that "if you are using Ubuntu 8.04 (Hardy Heron) everything will work out of the box" I would expect it to work in newer versions as well. –  user13792 Oct 20 '09 at 9:54

2 Answers 2

up vote 2 down vote accepted

First select a Microsoft keyboard in: System > Preferences > Keyboard > Layout > Keyboard Model. The 4000 isn't listed, but try the 'Multimedia keyboard' or something that sounds reasonably full-featured. They keys may just work. Try them, and change keyboards if they don't.

Then, you can try to customize things by the regular means (which in Ubuntu/GNOME is unfortunately not centralized, and can be tricky).

  1. On the same tab, check out the options in "Layout options"

  2. Customize more things in System > Preferences > Keyboard shortcuts. The options that are pre-defined here are pretty easy to set, you just select them and then press the key or key-combo you want to assign them to. This will be your most-used place for setting those keys.

  3. Gnome has a more cryptic tool, run from the command line as 'gconf-editor' which can assign key-combos to things that aren't in the standard Keyboard shortcuts dialog. You'll have to google on how to use this.

Hope this helps.

share|improve this answer
    
I did not find anything better than the "Microsoft Natural" that I already had and there weren't any useful options in 1). 2) worked for me. –  user13792 Oct 21 '09 at 8:22
    
Right. (1) above is just for non-mainstream customizations. Can be lifesaving, but not necessary for most people. (2) is where the goods are. Glad it worked. –  ScoBe Oct 21 '09 at 8:51
    
I had success selecting keyboard model Microsoft Inc. > Microsoft Natural Wireless Ergonomic Keyboard 7000. It appears to have the same layout as the 4000. The Web/Home button worked and I could program Keyboard Shortcuts for the My Favorites keys. –  frankadelic Jan 19 '12 at 16:54

A short solution description:

  1. System -> Preferences -> Keyboard Shortcuts
  2. Add
  3. Name: e.g. "Start MonoDevelop"
  4. Command: e.g. "monodevelop"
  5. Apply
  6. Click on the shortcut column at the "Start MonoDevelop" row
  7. Press the hotkey
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.