Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a touchscreen laptop running Windows 8, and when I bring the focus to an input field by tapping on it, the on-screen touch keyboard pops up. I find this really annoying.

After searching around, I found out that disabling the Touch Keyboard and Handwriting panel service (in services.msc) stops the keyboard from automatically popping up. The problem is, doing so disables the touch keyboard completely, so it doesn't even work when I click on the icon in the taskbar.

In short, I want to stop the touch keyboard from popping up when I tap in an input field, but I also want the keyboard to open when I click or tap on the icon in the taskbar so I can use the touch keyboard when I choose to.

Update:

To be specific, I actually want the icon on the taskbar, contrary to many other questions. I want to be able to use the keyboard when I click or tap on the icon, but I don't want it to automatically pop-up. The icon is already being shown in the taskbar, but nothing happens when I click or tap on it due to the service being disabled. Enabling the service makes the button work again, but then it pops up when I tap on a input field again

@DaveRook suggested I look in the Touch Keyboard options under Change PC Settings > General, but the options there seem to control typing on the keyboard, not when it is shown.

share|improve this question
    
+1 for a well worded question! Did you see all the answers on this post? superuser.com/questions/488322/… –  Dave Apr 3 '13 at 8:10
    
Thanks very much for taking an interest in this question and helping me out @DaveRook –  bungeshea Apr 3 '13 at 11:04
    
Not exactly what you want, but it's quite easy to turn it off which may suffice as a temporary work around: jholu.com/2012/09/26/onscreen-keyboard-of-windows-8 –  Dave Apr 3 '13 at 11:53

3 Answers 3

up vote 2 down vote accepted

Well unfortunately I have the same issue and I "hacked" my way through a solution. Perhaps someone else can make this better OR Microsoft could fix the keyboard to have a settings that makes the keyboard only come up on demand.

So you can stop and start services using batch files, plus you can disable and enable them as well. I wrote a couple of batch files that will start and stop the TabletInputService.

start_keyboard.bat has this in it:

sc config TabletInputService start= auto
net start TabletInputService

stop_keyboard.bat has this in it:

net stop TabletInputService
sc config TabletInputService start= disabled

Then you'll probably need to run these batch files as admin so I created desktop shortcuts to these batch files. Right-click the shortcuts, go to properties, click Advanced (under the Shortcut tab), click the Run as Administrator check box.

Now you can disable and enable when you want. I know it's a hack but this is the only solution I could think of. I've searched for a couple of days on Google for a solution and really this is the only question I've seen about this. Everyone just wants you to uninstall it or completely disable it.

Weird that Microsoft didn't think of putting in a setting called "only on demand" for this extremely obtrusive keyboard.

share|improve this answer
    
If you don't want to deal with the UAC prompt, follow the steps on this site: sevenforums.com/tutorials/… –  Bob Phrapples May 10 at 15:28

I had same problem, focusing to input area using touch screen and trying to enter with keyboard, pops up annoying touch keyboard.

Based on Bob's answer, I've created tool to easily switch service state, and also function to pop up touch keyboard once (enables temporary, and disables again).

Hope this helps someone.

http://win8room.net/en/2013/05/28/2486.html

share|improve this answer

I found a way to refine Bob's solution. It requires only one batch file to toggle the touch keyboard:

@echo off
sc query TabletInputService | find "RUNNING"
if "%ERRORLEVEL%"=="0" (
    sc config TabletInputService start= disabled
    net stop TabletInputService
) else (
    sc config TabletInputService start= auto
    net start TabletInputService
)
EXIT

Please keep in mind that you have to name your batch file extension .cmd - only then will you be able to find the "Run as Administrator" check box in the settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.